summaryrefslogtreecommitdiff
path: root/gnattools/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gnattools/configure.ac')
-rw-r--r--gnattools/configure.ac30
1 files changed, 21 insertions, 9 deletions
diff --git a/gnattools/configure.ac b/gnattools/configure.ac
index 0a94224a536..40d015ce8b0 100644
--- a/gnattools/configure.ac
+++ b/gnattools/configure.ac
@@ -51,15 +51,6 @@ ACX_NONCANONICAL_TARGET
# Need to pass this down for now :-P
AC_PROG_LN_S
-# Determine what to build for 'gnattools'
-if test $build = $target ; then
- # Note that build=target is almost certainly the wrong test; FIXME
- default_gnattools_target="gnattools-native"
-else
- default_gnattools_target="gnattools-cross"
-fi
-AC_SUBST([default_gnattools_target])
-
# Target-specific stuff (defaults)
TOOLS_TARGET_PAIRS=
AC_SUBST(TOOLS_TARGET_PAIRS)
@@ -135,6 +126,8 @@ esac
# From user or toplevel makefile.
AC_SUBST(ADA_CFLAGS)
+# This is testing the CC passed from the toplevel Makefile, not the
+# one we will select below.
AC_PROG_CC
warn_cflags=
if test "x$GCC" = "xyes"; then
@@ -142,6 +135,25 @@ if test "x$GCC" = "xyes"; then
fi
AC_SUBST(warn_cflags)
+# Determine what to build for 'gnattools'. Test after the above,
+# because testing for CC sets the final value of cross_compiling, even
+# if we end up using a different CC. We want to build
+# gnattools-native when: (a) this is a native build, i.e.,
+# cross_compiling=no, otherwise we know we cannot run binaries
+# produced by the toolchain used for the build, not even the binaries
+# created within ../gcc/; (b) build and host are the same, otherwise
+# this is to be regarded as a cross build environment even if it seems
+# that we can run host binaries; (c) host and target are the same,
+# otherwise the tools in ../gcc/ generate code for a different
+# platform. If you change this test, be sure to adjust
+# ../gcc/ada/gcc-interface/config-lang.in as well.
+if test "x$cross_compiling/$build/$host" = "xno/$host/$target" ; then
+ default_gnattools_target="gnattools-native"
+else
+ default_gnattools_target="gnattools-cross"
+fi
+AC_SUBST([default_gnattools_target])
+
# Output: create a Makefile.
AC_CONFIG_FILES([Makefile])