summaryrefslogtreecommitdiff
path: root/libstdc++-v3/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Kosnik <bkoz@redhat.com>2003-06-18 01:52:08 +0000
committerBenjamin Kosnik <bkoz@gcc.gnu.org>2003-06-18 01:52:08 +0000
commit0676e9308d8a96b0cefa5d59f2c8aa360e3cbf67 (patch)
treef6923f737c6fdecf4b68a349d75dd98053d0038c /libstdc++-v3/Makefile.am
parentb0c231bb70dc05847c7ea375ae4ffd78219e19aa (diff)
scripts: New.
2003-06-17 Benjamin Kosnik <bkoz@redhat.com> * scripts: New. * config/abi/extract_symvers: Move to... * scripts/extract_symvers: ...here. * mkcheck.in: Move to.. * scripts/check_survey.in: ...here. * testsuite_flags.in: Move to.. * scripts/testsuite_flags.in: ...here. * configure.in: Change check and testsuite_flags locations. * configure: Regenerate. * testsuite/Makefile.am (current_symbols.txt): Change location. * testsuite/Makefile.in: Regenerate. * testsuite/lib/libstdc++-v3-dg.exp (libstdc++-v3-init): Modify location of testsuite_flags. * Makefile.am (check-script): Move.. (check-script-install): Move... * testsuite/Makefile.am: ... here. * testsuite/Makefile.in: Regenerate. * Makefile.in: Regenerate. From-SVN: r68132
Diffstat (limited to 'libstdc++-v3/Makefile.am')
-rw-r--r--libstdc++-v3/Makefile.am15
1 files changed, 0 insertions, 15 deletions
diff --git a/libstdc++-v3/Makefile.am b/libstdc++-v3/Makefile.am
index 58edd36937a..2467ce3d7b8 100644
--- a/libstdc++-v3/Makefile.am
+++ b/libstdc++-v3/Makefile.am
@@ -31,21 +31,6 @@ mkinstalldirs = $(SHELL) $(toplevel_srcdir)/mkinstalldirs
PWD = $${PWDCMD-pwd}
-# These two special 'check-script' rules use the bash script 'mkcheck'
-# to do testing. This script is not as portable as the dejagnu test
-# harness, and is thus off by default. It does produce interesting
-# output however, including various performance analysis items like
-# compile time, execution time, and binary size.
-check-script: $(top_builddir)/mkcheck
- -(chmod + $(top_builddir)/mkcheck; \
- cd testsuite; \
- @glibcpp_builddir@/mkcheck 0)
-
-check-script-install: $(top_builddir)/mkcheck
- -(chmod + $(top_builddir)/mkcheck; \
- cd testsuite; \
- @glibcpp_builddir@/mkcheck 1)
-
# These rules are messy, but are hella worth it.
doxygen:
-(srcdir=`cd ${top_srcdir}; ${PWD}`; \