summaryrefslogtreecommitdiff
path: root/libsanitizer/Makefile.am
diff options
context:
space:
mode:
authorJakub Jelinek <jakub@redhat.com>2012-11-23 01:31:54 +0100
committerJakub Jelinek <jakub@gcc.gnu.org>2012-11-23 01:31:54 +0100
commit64548f3b797617cde14f01874e56c498fe7b5a48 (patch)
tree339414cc4c7cfeb18efd639d3d7dc3f403afa560 /libsanitizer/Makefile.am
parent8e5038ffa42bc77bce5fa30eb11e5c94fdb0fc74 (diff)
Makefile.am (AM_CXXFLAGS): Remove -Wno-variadic-macros.
* tsan/Makefile.am (AM_CXXFLAGS): Remove -Wno-variadic-macros. * Makefile.am (SUBDIRS): Guard tsan addition with TSAN_SUPPORTED automake conditional instead of !MULTISUBDIR32. * configure.tgt: Set TSAN_SUPPORTED=yes for x86_64/i686-linux for 64-bit multilib. * configure.ac: Check for void * size, source in configure.tgt, define TSAN_SUPPORTED conditional instead of MULTILIBDIR32. * configure: Regenerated. * Makefile.in: Regenerated. * tsan/Makefile.in: Regenerated. From-SVN: r193741
Diffstat (limited to 'libsanitizer/Makefile.am')
-rw-r--r--libsanitizer/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/libsanitizer/Makefile.am b/libsanitizer/Makefile.am
index d2192b2d38f..64d3d2eab9a 100644
--- a/libsanitizer/Makefile.am
+++ b/libsanitizer/Makefile.am
@@ -1,9 +1,9 @@
ACLOCAL_AMFLAGS = -I .. -I ../config
-if MULTISUBDIR32
-SUBDIRS = interception sanitizer_common asan
-else
+if TSAN_SUPPORTED
SUBDIRS = interception sanitizer_common asan tsan
+else
+SUBDIRS = interception sanitizer_common asan
endif
# Work around what appears to be a GNU make bug handling MAKEFLAGS