summaryrefslogtreecommitdiff
path: root/libobjc/configure.ac
diff options
context:
space:
mode:
authorNicola Pero <nicola.pero@meta-innovation.com>2010-09-14 10:23:37 +0000
committerNicola Pero <nicola@gcc.gnu.org>2010-09-14 10:23:37 +0000
commitfd3125375f17ba4d47aaf00d0c5d16d72a24f4f8 (patch)
treea612f102fc0035c2f3ad31c1091a959c15fb4afc /libobjc/configure.ac
parent4359dc2a313d076c3e98f7f5c0b5455637e0b69e (diff)
In libobjc/: Implemented objc_sync_enter() and objc_sync_exit(), which are required by @synchronized() to work.
In libobjc/: Implemented objc_sync_enter() and objc_sync_exit(), which are required by @synchronized() to work. * objc-sync.c: New file. * objc/objc-sync.h: New file. * objc-private/objc-sync.h: New file. * init.c (__objc_exec_class): Call __objc_sync_init() during the Objective-C runtime startup. * Makefile.in: Added objc-sync.c and objc-sync.h. * configure.ac: Added GCC_CHECK_TLS. * acinclude.m4: Include ../config/enable.m4 and ../config/tls.m4. * configure: Regenerated. * config.h.in: Regenerated. From-SVN: r164276
Diffstat (limited to 'libobjc/configure.ac')
-rw-r--r--libobjc/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/libobjc/configure.ac b/libobjc/configure.ac
index 8820edc7e64..ed532fab025 100644
--- a/libobjc/configure.ac
+++ b/libobjc/configure.ac
@@ -215,6 +215,8 @@ if test $target_thread_file != single; then
[Define if the compiler has a thread header that is non single.])
fi
+# Check if we have thread-local storage
+GCC_CHECK_TLS
AC_MSG_CHECKING([for exception model to use])
AC_LANG_PUSH(C)