summaryrefslogtreecommitdiff
path: root/libgo/configure.ac
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@gcc.gnu.org>2018-10-31 20:46:17 +0000
committerIan Lance Taylor <ian@gcc.gnu.org>2018-10-31 20:46:17 +0000
commit73b6d7a990b6ac6d06213814adf9cbd074c46dd6 (patch)
treefee9a63129007d8624e6b52861e2f90e7290fbfa /libgo/configure.ac
parentcdf0919d6de9594ca7711c5a03cf4c4068874805 (diff)
re PR bootstrap/82856 (--enable-maintainter-mode broken by incompatiblity of gcc's required automake and modern Perl)
PR bootstrap/82856 libgo: update to autoconf 2.69 and automake 1.15.1 Initial patch from Joseph Myers. Reviewed-on: https://go-review.googlesource.com/c/146417 From-SVN: r265701
Diffstat (limited to 'libgo/configure.ac')
-rw-r--r--libgo/configure.ac74
1 files changed, 41 insertions, 33 deletions
diff --git a/libgo/configure.ac b/libgo/configure.ac
index e2193a52f4a..180b4f434e2 100644
--- a/libgo/configure.ac
+++ b/libgo/configure.ac
@@ -6,7 +6,6 @@
# Process this file with autoreconf to produce configure.
-AC_PREREQ(2.64)
AC_INIT(package-unused, version-unused,, libgo)
AC_CONFIG_SRCDIR(Makefile.am)
AC_CONFIG_HEADER(config.h)
@@ -19,7 +18,7 @@ AM_ENABLE_MULTILIB(, ..)
AC_CANONICAL_SYSTEM
target_alias=${target_alias-$host_alias}
-AM_INIT_AUTOMAKE([1.9.3 no-define foreign no-dist -Wall -Wno-portability])
+AM_INIT_AUTOMAKE([1.9.3 no-define foreign no-dist subdir-objects -Wall -Wno-portability -Wno-override])
AH_TEMPLATE(PACKAGE, [Name of package])
AH_TEMPLATE(VERSION, [Version number of package])
@@ -248,15 +247,17 @@ case ${host} in
changequote(,)dnl
i[34567]86-*-* | x86_64-*-*)
changequote([,])dnl
- AC_COMPILE_IFELSE([
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#ifdef __x86_64__
#error 64-bit
-#endif],
+#endif
+])],
[GOARCH=386],
- AC_COMPILE_IFELSE([
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#ifdef __ILP32__
#error x32
-#endif],
+#endif
+])],
[GOARCH=amd64],
[GOARCH=amd64p32]))
;;
@@ -267,20 +268,23 @@ changequote([,])dnl
GOARCH=m68k
;;
mips*-*-*)
- AC_COMPILE_IFELSE([
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#if _MIPS_SIM != _ABIO32
#error not o32
-#endif],
+#endif
+])],
[mips_abi="o32"],
- [AC_COMPILE_IFELSE([
+ [AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#if _MIPS_SIM != _ABIN32
#error not n32
-#endif],
+#endif
+])],
[mips_abi="n32"],
- [AC_COMPILE_IFELSE([
+ [AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#if _MIPS_SIM != _ABI64
#error not n64
-#endif],
+#endif
+])],
[mips_abi="n64"],
[AC_MSG_ERROR([unknown MIPS ABI])
[mips_abi="n32"]])])])
@@ -299,16 +303,18 @@ changequote([,])dnl
GOARCH=nios2
;;
rs6000*-*-* | powerpc*-*-*)
- AC_COMPILE_IFELSE([
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#ifdef _ARCH_PPC64
#error 64-bit
-#endif],
+#endif
+])],
[GOARCH=ppc],
[
-AC_COMPILE_IFELSE([
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#if defined(_BIG_ENDIAN) || defined(__BIG_ENDIAN__)
#error 64be
-#endif],
+#endif
+])],
[GOARCH=ppc64le],
[GOARCH=ppc64])])
;;
@@ -316,10 +322,11 @@ AC_COMPILE_IFELSE([
GOARCH=riscv64
;;
s390*-*-*)
- AC_COMPILE_IFELSE([
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#if defined(__s390x__)
#error 64-bit
-#endif],
+#endif
+])],
[GOARCH=s390],
[GOARCH=s390x])
;;
@@ -330,10 +337,11 @@ AC_COMPILE_IFELSE([
GOARCH=sh
;;
sparc*-*-*)
- AC_COMPILE_IFELSE([
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#if defined(__sparcv9) || defined(__arch64__)
#error 64-bit
-#endif],
+#endif
+])],
[GOARCH=sparc],
[GOARCH=sparc64])
;;
@@ -389,7 +397,7 @@ AC_CACHE_CHECK([whether -fsplit-stack is supported],
[libgo_cv_c_split_stack_supported],
[CFLAGS_hold=$CFLAGS
CFLAGS="$CFLAGS -fsplit-stack"
-AC_COMPILE_IFELSE([[int i;]],
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([int i;])],
[libgo_cv_c_split_stack_supported=yes],
[libgo_cv_c_split_stack_supported=no])
CFLAGS=$CFLAGS_hold])
@@ -505,7 +513,7 @@ AC_CACHE_CHECK([whether -pthread is supported],
[libgo_cv_lib_pthread],
[CFLAGS_hold=$CFLAGS
CFLAGS="$CFLAGS -pthread -L../libatomic/.libs"
-AC_COMPILE_IFELSE([[int i;]],
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([int i;])],
[libgo_cv_lib_pthread=yes],
[libgo_cv_lib_pthread=no])
CFLAGS=$CFLAGS_hold])
@@ -572,11 +580,11 @@ LIBS="$LIBS_hold"
AC_CACHE_CHECK([for __sync_bool_compare_and_swap_4],
[libgo_cv_func___sync_bool_compare_and_swap_4],
-[AC_LINK_IFELSE([
+[AC_LINK_IFELSE([AC_LANG_SOURCE([
typedef unsigned int uint32 __attribute__ ((mode (SI)));
uint32 i;
int main() { return __sync_bool_compare_and_swap (&i, 0, 1); }
-],
+])],
[libgo_cv_func___sync_bool_compare_and_swap_4=yes],
[libgo_cv_func___sync_bool_compare_and_swap_4=no])])
if test "$libgo_cv_func___sync_bool_compare_and_swap_4" = "yes"; then
@@ -586,11 +594,11 @@ fi
AC_CACHE_CHECK([for __sync_bool_compare_and_swap_8],
[libgo_cv_func___sync_bool_compare_and_swap_8],
-[AC_LINK_IFELSE([
+[AC_LINK_IFELSE([AC_LANG_SOURCE([
typedef unsigned int uint64 __attribute__ ((mode (DI)));
uint64 i;
int main() { return __sync_bool_compare_and_swap (&i, 0, 1); }
-],
+])],
[libgo_cv_func___sync_bool_compare_and_swap_8=yes],
[libgo_cv_func___sync_bool_compare_and_swap_8=no])])
if test "$libgo_cv_func___sync_bool_compare_and_swap_8" = "yes"; then
@@ -600,11 +608,11 @@ fi
AC_CACHE_CHECK([for __sync_fetch_and_add_4],
[libgo_cv_func___sync_fetch_and_add_4],
-[AC_LINK_IFELSE([
+[AC_LINK_IFELSE([AC_LANG_SOURCE([
typedef unsigned int uint32 __attribute__ ((mode (SI)));
uint32 i;
int main() { return __sync_fetch_and_add (&i, 1); }
-],
+])],
[libgo_cv_func___sync_fetch_and_add_4=yes],
[libgo_cv_func___sync_fetch_and_add_4=no])])
if test "$libgo_cv_func___sync_fetch_and_add_4" = "yes"; then
@@ -614,11 +622,11 @@ fi
AC_CACHE_CHECK([for __sync_add_and_fetch_8],
[libgo_cv_func___sync_add_and_fetch_8],
-[AC_LINK_IFELSE([
+[AC_LINK_IFELSE([AC_LANG_SOURCE([
typedef unsigned int uint64 __attribute__ ((mode (DI)));
uint64 i;
int main() { return __sync_add_and_fetch (&i, 1); }
-],
+])],
[libgo_cv_func___sync_add_and_fetch_8=yes],
[libgo_cv_func___sync_add_and_fetch_8=no])])
if test "$libgo_cv_func___sync_add_and_fetch_8" = "yes"; then
@@ -632,7 +640,7 @@ AC_CACHE_CHECK([whether compiler supports -minline-all-stringops],
[libgo_cv_c_stringops],
[CFLAGS_hold=$CFLAGS
CFLAGS="$CFLAGS -minline-all-stringops"
-AC_COMPILE_IFELSE([int i;],
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([int i;])],
[libgo_cv_c_stringops=yes],
[libgo_cv_c_stringops=no])
CFLAGS=$CFLAGS_hold])
@@ -648,7 +656,7 @@ AC_CACHE_CHECK([whether compiler supports -mfancy-math-387],
[libgo_cv_c_fancymath],
[CFLAGS_hold=$CFLAGS
CFLAGS="$CFLAGS -mfancy-math-387"
-AC_COMPILE_IFELSE([int i;],
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([int i;])],
[libgo_cv_c_fancymath=yes],
[libgo_cv_c_fancymath=no])
CFLAGS=$CFLAGS_hold])
@@ -819,7 +827,7 @@ AC_CACHE_CHECK([if compiler supports -Qunused-arguments],
[libgo_cv_c_unused_arguments],
[CFLAGS_hold=$CFLAGS
CFLAGS="$CFLAGS -Qunused-arguments"
-AC_COMPILE_IFELSE([[int i;]],
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([int i;])],
[libgo_cv_c_unused_arguments=yes],
[libgo_cv_c_unused_arguments=no])
CFLAGS=$CFLAGS_hold])