summaryrefslogtreecommitdiff
path: root/libgo/configure.ac
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@gcc.gnu.org>2016-08-07 22:32:46 +0000
committerIan Lance Taylor <ian@gcc.gnu.org>2016-08-07 22:32:46 +0000
commit4f8e688afc2506eddabbd279978474b42330dbde (patch)
tree8e220f52080a004ca3ebfa32b8532ab4dcd54c5d /libgo/configure.ac
parent531e5ae3cc5fbf208c6d149be1191552134a8d65 (diff)
internal/syscall/unix: fix syscalls for alpha, ia64, s390
Also change the configure script to set GOARCH correctly for ia64, and add ia64 as a processor to match.sh and gotest. Reviewed-on: https://go-review.googlesource.com/25549 From-SVN: r239225
Diffstat (limited to 'libgo/configure.ac')
-rw-r--r--libgo/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/libgo/configure.ac b/libgo/configure.ac
index e4b314e5f8c..21ece733f34 100644
--- a/libgo/configure.ac
+++ b/libgo/configure.ac
@@ -191,6 +191,7 @@ is_386=no
is_alpha=no
is_arm=no
is_arm64=no
+is_ia64=no
is_m68k=no
mips_abi=unknown
is_ppc=no
@@ -229,6 +230,10 @@ changequote([,])dnl
GOARCH=amd64
fi
;;
+ ia64-*-*)
+ is_ia64=yes
+ GOARCH=ia64
+ ;;
m68k*-*-*)
is_m68k=yes
GOARCH=m68k
@@ -311,6 +316,7 @@ AM_CONDITIONAL(LIBGO_IS_386, test $is_386 = yes)
AM_CONDITIONAL(LIBGO_IS_ALPHA, test $is_alpha = yes)
AM_CONDITIONAL(LIBGO_IS_ARM, test $is_arm = yes)
AM_CONDITIONAL(LIBGO_IS_ARM64, test $is_arm64 = yes)
+AM_CONDITIONAL(LIBGO_IS_IA64, test $is_ia64 = yes)
AM_CONDITIONAL(LIBGO_IS_M68K, test $is_m68k = yes)
AM_CONDITIONAL(LIBGO_IS_MIPS, test $mips_abi != unknown)
AM_CONDITIONAL(LIBGO_IS_MIPSO32, test $mips_abi = o32)