summaryrefslogtreecommitdiff
path: root/libgo/Makefile.am
diff options
context:
space:
mode:
authorIan Lance Taylor <iant@golang.org>2017-01-14 00:05:42 +0000
committerIan Lance Taylor <ian@gcc.gnu.org>2017-01-14 00:05:42 +0000
commitc2047754c300b68c05d65faa8dc2925fe67b71b4 (patch)
treee183ae81a1f48a02945cb6de463a70c5be1b06f6 /libgo/Makefile.am
parent829afb8f05602bb31c9c597b24df7377fed4f059 (diff)
libgo: update to Go 1.8 release candidate 1
Compiler changes: * Change map assignment to use mapassign and assign value directly. * Change string iteration to use decoderune, faster for ASCII strings. * Change makeslice to take int, and use makeslice64 for larger values. * Add new noverflow field to hmap struct used for maps. Unresolved problems, to be fixed later: * Commented out test in go/types/sizes_test.go that doesn't compile. * Commented out reflect.TestStructOf test for padding after zero-sized field. Reviewed-on: https://go-review.googlesource.com/35231 gotools/: Updates for Go 1.8rc1. * Makefile.am (go_cmd_go_files): Add bug.go. (s-zdefaultcc): Write defaultPkgConfig. * Makefile.in: Rebuild. From-SVN: r244456
Diffstat (limited to 'libgo/Makefile.am')
-rw-r--r--libgo/Makefile.am43
1 files changed, 40 insertions, 3 deletions
diff --git a/libgo/Makefile.am b/libgo/Makefile.am
index fed41117716..0d9b7a7f6ad 100644
--- a/libgo/Makefile.am
+++ b/libgo/Makefile.am
@@ -346,7 +346,8 @@ toolexeclibgoruntimedir = $(toolexeclibgodir)/runtime
toolexeclibgoruntime_DATA = \
runtime/debug.gox \
- runtime/pprof.gox
+ runtime/pprof.gox \
+ runtime/trace.gox
toolexeclibgosyncdir = $(toolexeclibgodir)/sync
@@ -669,6 +670,7 @@ PACKAGES = \
archive/zip \
bufio \
bytes \
+ cmd/internal/browser \
compress/bzip2 \
compress/flate \
compress/gzip \
@@ -686,6 +688,7 @@ PACKAGES = \
crypto/ecdsa \
crypto/elliptic \
crypto/hmac \
+ crypto/internal/cipherhw \
crypto/md5 \
crypto/rand \
crypto/rc4 \
@@ -736,8 +739,16 @@ PACKAGES = \
go/scanner \
go/token \
go/types \
+ golang_org/x/crypto/chacha20poly1305 \
+ golang_org/x/crypto/chacha20poly1305/internal/chacha20 \
+ golang_org/x/crypto/curve25519 \
+ golang_org/x/crypto/poly1305 \
golang_org/x/net/http2/hpack \
+ golang_org/x/net/idna \
golang_org/x/net/lex/httplex \
+ golang_org/x/text/transform \
+ golang_org/x/text/unicode/norm \
+ golang_org/x/text/width \
hash \
hash/adler32 \
hash/crc32 \
@@ -755,6 +766,7 @@ PACKAGES = \
image/png \
index/suffixarray \
internal/nettrace \
+ internal/pprof/profile \
internal/race \
internal/singleflight \
internal/syscall/unix \
@@ -802,6 +814,8 @@ PACKAGES = \
runtime/internal/atomic \
runtime/internal/sys \
runtime/pprof \
+ runtime/pprof/internal/protopprof \
+ runtime/trace \
sort \
strconv \
strings \
@@ -809,6 +823,7 @@ PACKAGES = \
sync/atomic \
syscall \
testing \
+ testing/internal/testdeps \
testing/iotest \
testing/quick \
text/scanner \
@@ -829,6 +844,7 @@ libgo_go_objs = \
syscall/errno.lo \
syscall/signame.lo \
syscall/wait.lo \
+ $(golang_org_x_net_lif_lo) \
$(golang_org_x_net_route_lo) \
log/syslog/syslog_c.lo \
$(os_lib_inotify_lo) \
@@ -1113,7 +1129,7 @@ if LIBGO_IS_BSD
# Build golang_org/x/net/route only on BSD systems.
-$(eval $(call PACKAGE_template,golang_org/x/net/route)
+$(eval $(call PACKAGE_template,golang_org/x/net/route))
golang_org_x_net_route_lo = \
golang_org/x/net/route/route.lo
@@ -1122,6 +1138,19 @@ golang_org_x_net_route_check = \
endif
+if LIBGO_IS_SOLARIS
+
+# Build golang_org/x/net/lif only on Solaris systems.
+
+$(eval $(call PACKAGE_template,golang_org/x/net/lif))
+
+golang_org_x_net_lif_lo = \
+ golang_org/x/net/lif/lif.lo
+golang_org_x_net_lif_check = \
+ golang_org/x/net/lif/check
+
+endif
+
TEST_PACKAGES = \
bufio/check \
bytes/check \
@@ -1209,8 +1238,14 @@ TEST_PACKAGES = \
go/scanner/check \
go/token/check \
go/types/check \
+ golang_org/x/crypto/chacha20poly1305/check \
+ golang_org/x/crypto/chacha20poly1305/internal/chacha20/check \
+ golang_org/x/crypto/curve25519/check \
+ golang_org/x/crypto/poly1305/check \
golang_org/x/net/http2/hpack/check \
+ golang_org/x/net/idna/check \
golang_org/x/net/lex/httplex/check \
+ $(golang_org_x_net_lif_check) \
$(golang_org_x_net_route_check) \
hash/adler32/check \
hash/crc32/check \
@@ -1221,6 +1256,7 @@ TEST_PACKAGES = \
image/jpeg/check \
image/png/check \
index/suffixarray/check \
+ internal/pprof/profile/check \
internal/singleflight/check \
internal/trace/check \
io/ioutil/check \
@@ -1251,9 +1287,10 @@ TEST_PACKAGES = \
path/filepath/check \
regexp/syntax/check \
runtime/debug/check \
- runtime/pprof/check \
runtime/internal/atomic/check \
runtime/internal/sys/check \
+ runtime/pprof/check \
+ runtime/pprof/internal/protopprof/check \
sync/atomic/check \
text/scanner/check \
text/tabwriter/check \