summaryrefslogtreecommitdiff
path: root/libgo/Makefile.am
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@gcc.gnu.org>2017-01-20 21:18:37 +0000
committerIan Lance Taylor <ian@gcc.gnu.org>2017-01-20 21:18:37 +0000
commit4a5b806048bb94e2adcd34ea11ae27ca4030051f (patch)
tree93038434ff16825833e5bb4fd64a08717fe4c31f /libgo/Makefile.am
parenta876231c40c9e3488d91bd64aa7a12c939babe51 (diff)
runtime, testing/internal/testdeps: fixes for cgo
Some fixes that permit misc/cgo/test in the master gc repository to pass using the current gccgo. Install testing/internal/testdeps.gox; it is needed by `go test`. Export runtime.lockedOSThread to enable calling via go:linkname; it is used by misc/cgo/test. Loop on EAGAIN when creating a new thread; this is what the gc code does, and misc/cgo/test tests that it works. Reviewed-on: https://go-review.googlesource.com/35479 From-SVN: r244733
Diffstat (limited to 'libgo/Makefile.am')
-rw-r--r--libgo/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/libgo/Makefile.am b/libgo/Makefile.am
index 14ee9bec211..515b61b71e4 100644
--- a/libgo/Makefile.am
+++ b/libgo/Makefile.am
@@ -360,6 +360,11 @@ toolexeclibgotesting_DATA = \
testing/iotest.gox \
testing/quick.gox
+toolexeclibgotestinginternaldir = $(toolexeclibgotestingdir)/internal
+
+toolexeclibgotestinginternal_DATA = \
+ testing/internal/testdeps.gox
+
toolexeclibgotextdir = $(toolexeclibgodir)/text
toolexeclibgotext_DATA = \