summaryrefslogtreecommitdiff
path: root/libatomic/Makefile.am
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2015-11-18 22:13:44 +0000
committerJoseph Myers <jsm28@gcc.gnu.org>2015-11-18 22:13:44 +0000
commitc29c36ad5d0b283404cbbaae75a4b9fb827491f2 (patch)
tree08274b8bbbefd907bbf6dbb3658d87467546b2a9 /libatomic/Makefile.am
parent2b2a2e9e1eb75ccb1adabaa2a65716c17707a7b9 (diff)
Add out-of-line versions of some <stdatomic.h> functions (PR c/65083).
PR c/65083 notes that some functions in <stdatomic.h> are normal functions, not generic functions, and so need to have out-of-line copies that can be called when macro expansion is suppressed (unlike the generic functions where DR#419 makes it undefined if you suppress a macro expansion). This patch adds such out-of-line definitions in libatomic for those six functions, at a new LIBATOMIC_1.2 symbol version, as trivial wrappers to the <stdatomic.h> macros, along with declarations of those functions in <stdatomic.h>. Tests are added that are based on the corresponding tests for the macros, but with parentheses around the function names to force the out-of-line functions to be used. Bootstrapped with no regressions on x86_64-pc-linux-gnu. gcc: * ginclude/stdatomic.h (atomic_thread_fence, atomic_signal_fence) (atomic_flag_test_and_set, atomic_flag_test_and_set_explicit) (atomic_flag_clear, atomic_flag_clear_explicit): Declare as functions before defining as macros. gcc/testsuite: * gcc.dg/atomic/stdatomic-fence-2.c, gcc.dg/atomic/stdatomic-flag-2.c: New tests. libatomic: * fence.c, flag.c: New files. * Makefile.am (libatomic_la_SOURCES): Add fence.c and flag.c. * Makefile.in: Regenerate. * configure.ac (libtool_VERSION): Change to 3:0:2. * configure: Regenerate. * libatomic.map (LIBATOMIC_1.2): New symbol version. From-SVN: r230578
Diffstat (limited to 'libatomic/Makefile.am')
-rw-r--r--libatomic/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libatomic/Makefile.am b/libatomic/Makefile.am
index 3d8ab62dc8f..bd0ab293131 100644
--- a/libatomic/Makefile.am
+++ b/libatomic/Makefile.am
@@ -68,7 +68,7 @@ libatomic_version_info = -version-info $(libtool_VERSION)
libatomic_la_LDFLAGS = $(libatomic_version_info) $(libatomic_version_script) $(lt_host_flags)
libatomic_la_SOURCES = gload.c gstore.c gcas.c gexch.c glfree.c lock.c init.c \
- fenv.c
+ fenv.c fence.c flag.c
SIZEOBJS = load store cas exch fadd fsub fand fior fxor fnand tas
SIZES = @SIZES@