summaryrefslogtreecommitdiff
path: root/libatomic/Makefile.am
diff options
context:
space:
mode:
authorSteve Ellcey <sellcey@cavium.com>2017-12-14 18:30:38 +0000
committerSteve Ellcey <sje@gcc.gnu.org>2017-12-14 18:30:38 +0000
commit9d0e85af87d9e7fe3bd68d1647b7c47ad299f011 (patch)
treee5a3ca9f6062a7f43dd9730ab98439e6fe3ebc86 /libatomic/Makefile.am
parent2004617a8c2e67005230ebfcbdd1e4216b411bf1 (diff)
Makefile.am (IFUNC_OPTIONS): Change aarch64 option from -march=armv8.1-a to -march=armv8-a+lse.
2017-12-14 Steve Ellcey <sellcey@cavium.com> * Makefile.am (IFUNC_OPTIONS): Change aarch64 option from -march=armv8.1-a to -march=armv8-a+lse. * configure.ac (*aarch64*): Check to see if compiler understands -march=armv8-a+lse option. * configure.tgt (*aarch64*): Only set try_ifunc if compiler understands -march=armv8-a+lse option. * Makefile.in: Regenerate. * testsuite/Makefile.in: Regenerate. * configure: Regenerate. * aclocal.m4: Regenerate. From-SVN: r255659
Diffstat (limited to 'libatomic/Makefile.am')
-rw-r--r--libatomic/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libatomic/Makefile.am b/libatomic/Makefile.am
index ec36c8ef207..21fd1bec1ed 100644
--- a/libatomic/Makefile.am
+++ b/libatomic/Makefile.am
@@ -123,7 +123,7 @@ libatomic_la_LIBADD = $(foreach s,$(SIZES),$(addsuffix _$(s)_.lo,$(SIZEOBJS)))
## On a target-specific basis, include alternates to be selected by IFUNC.
if HAVE_IFUNC
if ARCH_AARCH64_LINUX
-IFUNC_OPTIONS = -march=armv8.1-a
+IFUNC_OPTIONS = -march=armv8-a+lse
libatomic_la_LIBADD += $(foreach s,$(SIZES),$(addsuffix _$(s)_1_.lo,$(SIZEOBJS)))
endif
if ARCH_ARM_LINUX