summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorThomas Schwinge <thomas@codesourcery.com>2019-05-09 11:51:59 +0200
committerThomas Schwinge <tschwinge@gcc.gnu.org>2019-05-09 11:51:59 +0200
commit7d48b7adadcd717a1da26a1b1def98601d767099 (patch)
treec1feb728600d3250a2875b644d98f845101f24a6 /gcc/configure.ac
parentb2536b7c3de5aaaa18a5205a851d43059f868c57 (diff)
[PR89221] Continue to default to '--disable-frame-pointer' for x86 GNU systems
The recent trunk r270914 for PR89221 "--enable-frame-pointer does not work as intended" fixed a scripting defect in the x86 '--enable-frame-pointer' handling. This has the side effect that, for example, for '--target=i686-gnu' this is now enabled by default: 'USE_IX86_FRAME_POINTER=1' is added to 'tm_defines'. Given that it's highly unlikely that anyone would now suddenly want '--enable-frame-pointer' as the default for any kind of GNU system, I'm changing the default back for GNU systems, to match that of a 'target_os' of 'linux* | darwin[8912]*'. gcc/ PR target/89221 * configure.ac (--enable-frame-pointer): Disable by default for GNU systems. * configure: Regenerate. From-SVN: r271028
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index 7c526b9ada4..bfcdf526e44 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -1884,8 +1884,8 @@ AC_ARG_ENABLE(frame-pointer,
[enable -fno-omit-frame-pointer by default for x86])], [],
[
case $target_os in
-linux* | darwin[[8912]]*)
- # Enable -fomit-frame-pointer by default for Linux and Darwin with DWARF2.
+linux* | gnu* | darwin[[8912]]*)
+ # Enable -fomit-frame-pointer by default for these systems with DWARF2.
enable_frame_pointer=no
;;
*)