summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Jambor <jamborm@gcc.gnu.org>2017-01-27 15:35:07 +0100
committerMartin Jambor <jamborm@gcc.gnu.org>2017-01-27 15:35:07 +0100
commitf6a24a94a63abf72a349346c0af46426a63aba1a (patch)
tree5c230ebc44096ebc0fd8a1e52e8be49140663b98 /configure.ac
parent71103b610487c068e1bb379724f6bba1eafedb08 (diff)
[brigfe] Small fixes
2017-01-27 Pekka Jaaskelainen <pekka.jaaskelainen@parmance.com> * configure.ac: Moved the white list of enabling BRIG FE to libhsail-rt/configure.tgt. * configure: Regenerated. * MAINTAINERS: Updated maintainers for BRIG FE and libhsail-rt. gcc/ * builtin-types.def: Use unsigned_char_type_node for BT_UINT8. Use uint16_type_node for BT_UINT16. gcc/brig/ * config-lang.in: Removed stale target-libbrig reference. libhsail-rt/ * configure.tgt: Moved the white list of supported targets here from configure.ac. Added i[3456789]86-*-linux* as a supported env for the BRIG FE. * README: Added a proper description of what libhsail-rt is. From-SVN: r244978
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 17 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 5818332c7fc..17a9f17057b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -634,6 +634,23 @@ if test -d ${srcdir}/libmpx; then
fi
fi
+# Disable libhsail-rt on unsupported systems.
+if test -d ${srcdir}/libhsail-rt; then
+ if test x$enable_libhsail_rt = x; then
+ AC_MSG_CHECKING([for libhsail-rt support])
+ if (srcdir=${srcdir}/libhsail-rt; \
+ . ${srcdir}/configure.tgt; \
+ test -n "$UNSUPPORTED")
+ then
+ AC_MSG_RESULT([no])
+ unsupported_languages="$unsupported_languages brig"
+ # This implicitly disables also target-libhsail-rt as it won't
+ # get added to the build without BRIG FE.
+ else
+ AC_MSG_RESULT([yes])
+ fi
+ fi
+fi
# Disable libquadmath for some systems.
@@ -813,19 +830,6 @@ if test x$enable_libgo = x; then
esac
fi
-# Disable the BRIG frontend and libhsail-rt on untested or known
-# broken systems. Currently it has been tested only on x86_64 Linux
-# of the upstream gcc targets. More targets shall be added after testing.
-case "${target}" in
- x86_64-*-linux*)
- ;;
- *)
- unsupported_languages="$unsupported_languages brig"
- # This implicitly disables also target-libhsail-rt as it won't
- # get added to the build without BRIG FE.
- ;;
-esac
-
# Default libgloss CPU subdirectory.
libgloss_dir="$target_cpu"