summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew Haley <aph@gcc.gnu.org>2016-09-30 16:08:23 +0000
committerAndrew Haley <aph@gcc.gnu.org>2016-09-30 16:08:23 +0000
commiteae993948bae8b788c53772bcb9217c063716f93 (patch)
tree3d8f68d90942094bce367a38fde674a3e3e75c0a /configure.ac
parent37b204de605563e7932e26099d28ea8c86cb1935 (diff)
Makefile.def: Remove libjava.
2016-09-05 Andrew Haley <aph@redhat.com> * Makefile.def: Remove libjava. * Makefile.tpl: Likewise. * Makefile.in: Regenerate. * configure.ac: Likewise. * configure: Likewise. From-SVN: r240661
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac237
1 files changed, 0 insertions, 237 deletions
diff --git a/configure.ac b/configure.ac
index 7fa9c465fa7..d09796ee8ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,11 +142,6 @@ host_libs="intl libiberty opcodes bfd readline tcl tk itcl libgui zlib libbacktr
# If --enable-gold is used, "gold" may replace "ld".
host_tools="texinfo flex bison binutils gas ld fixincludes gcc cgen sid sim gdb gprof etc expect dejagnu m4 utils guile fastjar gnattools libcc1 gotools"
-# libgcj represents the runtime libraries only used by gcj.
-libgcj="target-libffi \
- target-zlib \
- target-libjava"
-
# these libraries are built for the target environment, and are built after
# the host libraries and the host tools (which may be a cross compiler)
# Note that libiberty is not a target library.
@@ -166,8 +161,6 @@ target_libraries="target-libgcc \
target-libssp \
target-libquadmath \
target-libgfortran \
- target-boehm-gc \
- ${libgcj} \
target-libobjc \
target-libada \
target-libgo"
@@ -507,41 +500,6 @@ else
fi])
AC_SUBST(extra_liboffloadmic_configure_flags)
-# Save it here so that, even in case of --enable-libgcj, if the Java
-# front-end isn't enabled, we still get libgcj disabled.
-libgcj_saved=$libgcj
-case $enable_libgcj in
-yes)
- # If we reset it here, it won't get added to noconfigdirs in the
- # target-specific build rules, so it will be forcibly enabled
- # (unless the Java language itself isn't enabled).
- libgcj=
- ;;
-no)
- # Make sure we get it printed in the list of not supported target libs.
- # Don't disable libffi, though, other languages use it.
- noconfigdirs="$noconfigdirs `echo ${libgcj} | sed -e 's/target-libffi//'`"
- # Clear libgcj_saved so that even if java is enabled libffi won't be
- # built.
- libgcj_saved=
- ;;
-esac
-
-AC_ARG_ENABLE(static-libjava,
-[AS_HELP_STRING([[--enable-static-libjava[=ARG]]],
- [build static libjava @<:@default=no@:>@])],
-ENABLE_STATIC_LIBJAVA=$enableval,
-ENABLE_STATIC_LIBJAVA=no)
-enable_static_libjava=
-if test "${ENABLE_STATIC_LIBJAVA}" = "yes" ; then
- enable_static_libjava=yes
-fi
-
-if test x$enable_static_libjava != xyes ; then
- EXTRA_CONFIGARGS_LIBJAVA=--disable-static
-fi
-AC_SUBST(EXTRA_CONFIGARGS_LIBJAVA)
-
# Enable libgomp by default on hosted POSIX systems, and a few others.
if test x$enable_libgomp = x ; then
case "${target}" in
@@ -738,166 +696,6 @@ case "${target}" in
;;
esac
-# Disable Java if libffi is not supported.
-case "${target}" in
- aarch64-*-*)
- ;;
- alpha*-*-*)
- ;;
- arm*-*-*)
- ;;
- cris-*-*)
- ;;
- frv-*-*)
- ;;
- hppa*-*-linux*)
- ;;
- hppa*-*-hpux*)
- ;;
- i?86-*-*)
- ;;
- ia64*-*-*)
- ;;
- m32r*-*-*)
- ;;
- m68k-*-*)
- ;;
- mips*-*-rtems*)
- ;;
- mips*-*-linux*)
- ;;
- powerpc*-*-linux*)
- ;;
- powerpc-*-darwin*)
- ;;
- powerpc-*-aix* | rs6000-*-aix*)
- ;;
- powerpc-*-freebsd*)
- ;;
- powerpc64-*-freebsd*)
- ;;
- powerpc*-*-rtems*)
- ;;
- s390-*-* | s390x-*-*)
- ;;
- sh-*-* | sh[[34]]*-*-*)
- ;;
- sparc*-*-*)
- ;;
- x86_64-*-*)
- ;;
- *-*-*)
- unsupported_languages="$unsupported_languages java"
- ;;
-esac
-
-# Disable Java, libgcj or related libraries for some systems.
-case "${target}" in
- powerpc-*-darwin*)
- ;;
- i[[3456789]]86-*-darwin*)
- ;;
- x86_64-*-darwin[[912]]*)
- ;;
- *-*-darwin*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- *-*-netware*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- *-*-phoenix*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- *-*-rtems*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- *-*-tpf*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- *-*-uclinux*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- *-*-vxworks*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- alpha*-*-*vms*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- arm*-*-freebsd*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- arm-wince-pe)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- arm*-*-symbianelf*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- bfin-*-*)
- noconfigdirs="$noconfigdirs target-boehm-gc"
- ;;
- cris-*-* | crisv32-*-*)
- unsupported_languages="$unsupported_languages java"
- case "${target}" in
- *-*-linux*)
- ;;
- *) # See PR46792 regarding target-libffi.
- noconfigdirs="$noconfigdirs target-libffi target-boehm-gc";;
- esac
- ;;
- hppa*64*-*-linux*)
- # In this case, it's because the hppa64-linux target is for
- # the kernel only at this point and has no libc, and thus no
- # headers, crt*.o, etc., all of which are needed by these.
- unsupported_languages="$unsupported_languages java"
- ;;
- hppa*64*-*-hpux*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- hppa*-hp-hpux11*)
- ;;
- hppa*-*-hpux*)
- # According to Alexandre Oliva <aoliva@redhat.com>, libjava won't
- # build on HP-UX 10.20.
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- ia64*-*-*vms*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- i[[3456789]]86-w64-mingw*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- i[[3456789]]86-*-mingw*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- x86_64-*-mingw*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- mmix-*-*)
- noconfigdirs="$noconfigdirs target-libffi target-boehm-gc"
- ;;
- powerpc-*-aix*)
- # copied from rs6000-*-* entry
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- rs6000-*-aix*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- ft32-*-*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
- *-*-lynxos*)
- noconfigdirs="$noconfigdirs ${libgcj}"
- ;;
-esac
-
-# Disable the go frontend on systems where it is known to not work. Please keep
-# this in sync with contrib/config-list.mk.
-case "${target}" in
-*-*-darwin* | *-*-cygwin* | *-*-mingw* | *-*-aix*)
- unsupported_languages="$unsupported_languages go"
- ;;
-esac
-
# Disable libgo for some systems where it is known to not work.
# For testing, you can easily override this with --enable-libgo.
if test x$enable_libgo = x; then
@@ -2160,30 +1958,6 @@ for dir in $configdirs $build_configdirs $target_configdirs ; do
fi
done
-# Check for Boehm's garbage collector
-AC_ARG_ENABLE(objc-gc,
-[AS_HELP_STRING([--enable-objc-gc],
- [enable use of Boehm's garbage collector with the
- GNU Objective-C runtime])],
-[case ,${enable_languages},:${enable_objc_gc}:${noconfigdirs} in
- *,objc,*:*:yes:*target-boehm-gc*)
- AC_MSG_ERROR([Boehm's garbage collector was requested yet not supported in this configuration])
- ;;
-esac])
-
-# Make sure we only build Boehm's garbage collector if required.
-case ,${enable_languages},:${enable_objc_gc} in
- *,objc,*:yes)
- # Keep target-boehm-gc if requested for Objective-C.
- ;;
- *)
- # Otherwise remove target-boehm-gc depending on target-libjava.
- if echo " ${noconfigdirs} " | grep "target-libjava" >/dev/null 2>&1; then
- noconfigdirs="$noconfigdirs target-boehm-gc"
- fi
- ;;
-esac
-
# Disable libcilkrts, libitm, libsanitizer, libvtv, liboffloadmic if we're not building C++
case ,${enable_languages}, in
*,c++,*)
@@ -2268,15 +2042,6 @@ for i in ${target_configdirs_all} ; do
fi
done
-# Exclude target-zlib if target-libjava isn't built.
-case ${target_configdirs} in
-*target-libjava*)
- ;;
-*)
- target_configdirs="`echo ${target_configdirs} | sed -e 's/target-zlib//'`"
- ;;
-esac
-
# libiberty-linker-plugin is special: it doesn't have its own source directory,
# so we have to add it after the preceding checks.
if test x"$extra_linker_plugin_flags$extra_linker_plugin_configure_flags" != x
@@ -3438,8 +3203,6 @@ GCC_TARGET_TOOL(c++ for libstdc++, RAW_CXX_FOR_TARGET, CXX,
c++)
GCC_TARGET_TOOL(dlltool, DLLTOOL_FOR_TARGET, DLLTOOL, [binutils/dlltool])
GCC_TARGET_TOOL(gcc, GCC_FOR_TARGET, , [gcc/xgcc -B$$r/$(HOST_SUBDIR)/gcc/])
-GCC_TARGET_TOOL(gcj, GCJ_FOR_TARGET, GCJ,
- [gcc/gcj -B$$r/$(HOST_SUBDIR)/gcc/], java)
GCC_TARGET_TOOL(gfortran, GFORTRAN_FOR_TARGET, GFORTRAN,
[gcc/gfortran -B$$r/$(HOST_SUBDIR)/gcc/], fortran)
GCC_TARGET_TOOL(gccgo, GOC_FOR_TARGET, GOC,