summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Jelinek <jakub@redhat.com>2016-12-21 12:28:40 +0100
committerJakub Jelinek <jakub@gcc.gnu.org>2016-12-21 12:28:40 +0100
commitc21fdaa1a7c7487015123c67b0cfde3497e2bdb9 (patch)
tree83fafe333e359a5a8e02482446c252b8e1ddd1f0 /configure.ac
parentdb313371c7e83f11b5a8ef4b3ac281b036e56c47 (diff)
configure.ac: Don't bootstrap libmpx unless --with-build-config includes bootstrap-mpx.
* configure.ac: Don't bootstrap libmpx unless --with-build-config includes bootstrap-mpx. * configure: Regenerated. From-SVN: r243849
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 51ee70507cf..0d6efcfe3a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2643,9 +2643,14 @@ if echo " ${target_configdirs} " | grep " libvtv " > /dev/null 2>&1 &&
bootstrap_target_libs=${bootstrap_target_libs}target-libvtv,
fi
-# If we are building libmpx, bootstrap it.
+# If we are building libmpx and $BUILD_CONFIG contains bootstrap-mpx,
+# bootstrap it.
if echo " ${target_configdirs} " | grep " libmpx " > /dev/null 2>&1; then
- bootstrap_target_libs=${bootstrap_target_libs}target-libmpx,
+ case "$BUILD_CONFIG" in
+ *bootstrap-mpx* )
+ bootstrap_target_libs=${bootstrap_target_libs}target-libmpx,
+ ;;
+ esac
fi
# Determine whether gdb needs tk/tcl or not.