summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Liska <mliska@suse.cz>2017-05-31 15:35:41 +0200
committerMartin Liska <marxin@gcc.gnu.org>2017-05-31 13:35:41 +0000
commitafd88efc0530ec39d926c9932e4302cff9a2e526 (patch)
tree7c6103623e39565d98c677d6ceaf43e0bd42dd61 /configure.ac
parenta02d1ad2b2973bcc047715b39df2ff1c69385541 (diff)
Fix configure.ac to respect --{enable,disable}-werror option.
2017-05-31 Martin Liska <mliska@suse.cz> * configure.ac: Add handling of stage2_werror_flags to action-if-given and to action-if-not-given. * configure: Regenerate. From-SVN: r248737
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 78d2d593106..82faf06946d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3508,12 +3508,14 @@ AC_SUBST(stage1_checking)
# Enable -Werror in bootstrap stage2 and later.
AC_ARG_ENABLE(werror,
[AS_HELP_STRING([--enable-werror],
- [enable -Werror in bootstrap stage2 and later])], [], [])
+ [enable -Werror in bootstrap stage2 and later])],
+[
case ${enable_werror} in
yes) stage2_werror_flag="--enable-werror-always" ;;
*) stage2_werror_flag="" ;;
esac
-
+],
+[
if test -d ${srcdir}/gcc && test x"`cat $srcdir/gcc/DEV-PHASE`" = xexperimental; then
case $BUILD_CONFIG in
bootstrap-debug)
@@ -3522,6 +3524,7 @@ if test -d ${srcdir}/gcc && test x"`cat $srcdir/gcc/DEV-PHASE`" = xexperimental;
stage2_werror_flag="--enable-werror-always" ;;
esac
fi
+])
AC_SUBST(stage2_werror_flag)