summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Tromey <tom@tromey.com>2019-06-15 21:32:03 +0000
committerTom Tromey <tromey@gcc.gnu.org>2019-06-15 21:32:03 +0000
commit98e5be211e3d59563e760feabb1d4384efe5a1b9 (patch)
treec6eb7127cefbbcee03ce166a54625f398533e595 /configure.ac
parentf6ebef4ebb56379020502ffb47e554ea3ffe764c (diff)
Sync top-level change from gdb
This patch syncs a change to the top-level configury from gdb. It should not affect the gcc build at all. Tested by rebuilding. ChangeLog 2019-06-15 Tom Tromey <tom@tromey.com> * configure.ac (host_libs): Add gnulib. * configure: Rebuild. * Makefile.def (host_modules, dependencies): Add gnulib. * Makefile.in: Rebuild. From-SVN: r272332
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5f02008dd15..dcc89fbdde1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000,
# 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012,
-# 2014, 2015, 2016 Free Software Foundation, Inc.
+# 2014, 2015, 2016, 2019 Free Software Foundation, Inc.
#
# This file is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by
@@ -2750,6 +2750,14 @@ esac
CONFIGURE_GDB_TK=`echo ${GDB_TK} | sed s/-all-/-configure-/g`
INSTALL_GDB_TK=`echo ${GDB_TK} | sed s/-all-/-install-/g`
+# gdb depends on gnulib, but as nothing else does, only include it if
+# gdb is built.
+if echo " ${configdirs} " | grep " gdb " > /dev/null 2>&1 ; then
+ # The Makefile provides the ordering, so it's enough here to add
+ # gnulib to the list.
+ configdirs="${configdirs} gnulib"
+fi
+
# Strip out unwanted targets.
# While at that, we remove Makefiles if we were started for recursive