summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMaciej W. Rozycki <macro@imgtec.com>2016-09-12 14:08:48 +0000
committerMaciej W. Rozycki <macro@gcc.gnu.org>2016-09-12 14:08:48 +0000
commit8f3675f855e0e95366ef53c6291835cc2fb597f7 (patch)
tree499e3e2edb3055a3109766948933ddaec1ef2d97 /configure.ac
parent527a3750579f5b8aa0b49129b80df48cfbaa5813 (diff)
configure.ac: Check for the minimum in-tree MPFR version handled.
* configure.ac: Check for the minimum in-tree MPFR version handled. * configure: Regenerate. From-SVN: r240092
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 51b53b5c56a..a1b9da4fa9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1546,6 +1546,11 @@ if test "x$with_mpfr_lib" != x; then
gmplibs="-L$with_mpfr_lib $gmplibs"
fi
if test "x$with_mpfr$with_mpfr_include$with_mpfr_lib" = x && test -d ${srcdir}/mpfr; then
+ # MPFR v3.1.0 moved the sources into a src sub-directory.
+ if ! test -d ${srcdir}/mpfr/src; then
+ AC_MSG_ERROR([dnl
+Building GCC with MPFR in the source tree is only handled for MPFR 3.1.0+.])
+ fi
gmplibs='-L$$r/$(HOST_SUBDIR)/mpfr/src/'"$lt_cv_objdir $gmplibs"
gmpinc='-I$$r/$(HOST_SUBDIR)/mpfr/src -I$$s/mpfr/src '"$gmpinc"
extra_mpc_mpfr_configure_flags='--with-mpfr-include=$$s/mpfr/src --with-mpfr-lib=$$r/$(HOST_SUBDIR)/mpfr/src/'"$lt_cv_objdir"