summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Klose <doko@gcc.gnu.org>2016-12-01 12:31:49 +0000
committerMatthias Klose <doko@gcc.gnu.org>2016-12-01 12:31:49 +0000
commit825fba526ce816bd26887457e2f0f4ca05b1ccdd (patch)
tree4c583720979cd6e40f2597acf959a71ad777098d /configure.ac
parenta41e62e743af77da51413bd6f865f4c270f11674 (diff)
configure.ac: Don't use pkg-config to check for bdw-gc.
<toplevel> * configure.ac: Don't use pkg-config to check for bdw-gc. * configure: Regenerate. config/ * pkg.m4: Remove. libobjc/ * configure.ac: Don't use pkg-config to check for bdw-gc. * configure: Regenerate. gcc/ * doc/install.texi: Don't use pkg-config to check for bdw-gc. From-SVN: r243108
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ed89ea22c24..51ee70507cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,7 +29,6 @@ m4_include([ltsugar.m4])
m4_include([ltversion.m4])
m4_include([lt~obsolete.m4])
m4_include([config/isl.m4])
-m4_include([config/pkg.m4])
AC_INIT(move-if-change)
AC_PREREQ(2.64)
@@ -2076,10 +2075,8 @@ AC_ARG_WITH([target-bdw-gc-lib],
case ,${enable_languages},:${enable_objc_gc} in *,objc,*:yes|*,objc,*:auto)
AC_MSG_CHECKING([for bdw garbage collector])
if test "x$with_target_bdw_gc$with_target_bdw_gc_include$with_target_bdw_gc_lib" = x; then
- dnl no bdw-gw options, fall back to the bdw-gc pkg-config module
- PKG_CHECK_EXISTS(bdw-gc,
- AC_MSG_RESULT([using bdw-gc pkg-config module]),
- AC_MSG_ERROR([no --with-target-bdw-gc options and no bdw-gc pkg-config module found]))
+ dnl no bdw-gw options, assume default locations
+ AC_MSG_RESULT([using bdw-gc in default locations])
else
dnl bdw-gw options, first error checking, complete checking in libobjc
if test "x$with_target_bdw_gc_include" = x && test "x$with_target_bdw_gc_lib" != x; then