summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIain Buclaw <ibuclaw@gdcproject.org>2018-10-31 09:44:31 +0000
committerIain Buclaw <ibuclaw@gcc.gnu.org>2018-10-31 09:44:31 +0000
commit260eedb901c1b3df69598a724e23e33674ab654b (patch)
tree10a9f6234a9102bf5882d279f041372de9c32588 /configure.ac
parentd400fda3a8c3330f77eb9d51874f5482d3819a9f (diff)
re PR d/87788 (Support D on x86_64-apple-darwin*)
ChangeLog: 2018-10-31 Iain Buclaw <ibuclaw@gdcproject.org> PR bootstrap/87788 PR d/87799 * configure: Rebuild. * configure.ac: Disable D on systems where it is known not to work. libphobos/ChangeLog: 2018-10-31 Iain Buclaw <ibuclaw@gdcproject.org> PR bootstrap/87789 PR d/87818 PR d/87819 * configure.tgt: New file. From-SVN: r265658
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1e5979dc043..b10212b3be5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -674,6 +674,37 @@ if test "${ENABLE_LIBSTDCXX}" = "default" ; then
esac
fi
+# Disable D on systems where it is known to not work.
+# For testing, you can override this with --enable-languages=d.
+case ,${enable_languages}, in
+ *,d,*)
+ ;;
+ *)
+ case "${target}" in
+ *-*-darwin* | *-*-cygwin* | *-*-mingw*)
+ unsupported_languages="$unsupported_languages d"
+ ;;
+ esac
+ ;;
+esac
+
+# Disable libphobos on unsupported systems.
+# For testing, you can override this with --enable-libphobos.
+if test -d ${srcdir}/libphobos; then
+ if test x$enable_libphobos = x; then
+ AC_MSG_CHECKING([for libphobos support])
+ if (srcdir=${srcdir}/libphobos; \
+ . ${srcdir}/configure.tgt; \
+ test -n "$UNSUPPORTED")
+ then
+ AC_MSG_RESULT([no])
+ noconfigdirs="$noconfigdirs target-libphobos"
+ else
+ AC_MSG_RESULT([yes])
+ fi
+ fi
+fi
+
# Disable Fortran for some systems.
case "${target}" in
mmix-*-*)