summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-tsd_6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-tsd_6.0.bb')
-rw-r--r--recipes-kernel/linux/linux-tsd_6.0.bb16
1 files changed, 12 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-tsd_6.0.bb b/recipes-kernel/linux/linux-tsd_6.0.bb
index d3e3119..db9bc26 100644
--- a/recipes-kernel/linux/linux-tsd_6.0.bb
+++ b/recipes-kernel/linux/linux-tsd_6.0.bb
@@ -9,16 +9,21 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
inherit kernel
-SRC_GIT_REPO = "git://git.theobroma-systems.com/ringneck-linux.git"
+SRC_GIT_REPO:ringneck-haikou = "git://git.theobroma-systems.com/ringneck-linux.git"
+SRC_GIT_REPO:puma-haikou = "git://git.theobroma-systems.com/puma-linux.git"
SRC_GIT_REPO_PROTO = ";protocol=https"
-SRC_GIT_BRANCH = ";branch=v6.0.2-ringneck"
+SRC_GIT_BRANCH:ringneck-haikou = ";branch=v6.0.2-ringneck"
+SRC_GIT_BRANCH:puma-haikou = ";branch=v6.0.2-puma"
+
+COMPATIBLE_MACHINE = "(puma-haikou|ringneck-haikou)"
SRC_URI = " \
${SRC_GIT_REPO}${SRC_GIT_REPO_PROTO}${SRC_GIT_BRANCH} \
${SRC_URI_PATCHES} \
"
-SRCREV = "de748a4593915b3566233e6724bac9ecb4418e38"
+SRCREV:ringneck-haikou = "805aa082cec9a41c51e8af36c5092495e37388da"
+SRCREV:puma-haikou = "7624b244784bd19b4f5100a94ea3ac2bb1f3624d"
S = "${WORKDIR}/git"
@@ -26,7 +31,10 @@ SRC_URI_PATCHES ?= ""
LINUX_VERSION ?= "6.0.2"
-DEFCONFIG ?= "ringneck-px30_defconfig"
+DEFCONFIG:ringneck-haikou ?= "ringneck-px30_defconfig"
+DEFCONFIG:puma-haikou ?= "puma-rk3399_defconfig"
+
+KERNEL_DEVICETREE:prepend:puma-haikou = "rockchip/rk3399-puma-haikou-video-demo.dtb "
# Borrowed from kernel-yocto.bbclass:do_kernel_metadata()
do_configure:prepend () {