summaryrefslogtreecommitdiff
path: root/package/linux-tools
diff options
context:
space:
mode:
Diffstat (limited to 'package/linux-tools')
-rw-r--r--package/linux-tools/linux-tool-cpupower.mk.in (renamed from package/linux-tools/linux-tool-cpupower.mk)0
-rw-r--r--package/linux-tools/linux-tool-gpio.mk.in (renamed from package/linux-tools/linux-tool-gpio.mk)0
-rw-r--r--package/linux-tools/linux-tool-iio.mk.in (renamed from package/linux-tools/linux-tool-iio.mk)0
-rw-r--r--package/linux-tools/linux-tool-perf.mk.in (renamed from package/linux-tools/linux-tool-perf.mk)0
-rw-r--r--package/linux-tools/linux-tool-selftests.mk.in (renamed from package/linux-tools/linux-tool-selftests.mk)0
-rw-r--r--package/linux-tools/linux-tools.mk17
6 files changed, 8 insertions, 9 deletions
diff --git a/package/linux-tools/linux-tool-cpupower.mk b/package/linux-tools/linux-tool-cpupower.mk.in
index 2a2d3e01dd..2a2d3e01dd 100644
--- a/package/linux-tools/linux-tool-cpupower.mk
+++ b/package/linux-tools/linux-tool-cpupower.mk.in
diff --git a/package/linux-tools/linux-tool-gpio.mk b/package/linux-tools/linux-tool-gpio.mk.in
index ba75ab4c3f..ba75ab4c3f 100644
--- a/package/linux-tools/linux-tool-gpio.mk
+++ b/package/linux-tools/linux-tool-gpio.mk.in
diff --git a/package/linux-tools/linux-tool-iio.mk b/package/linux-tools/linux-tool-iio.mk.in
index 60d6249d2f..60d6249d2f 100644
--- a/package/linux-tools/linux-tool-iio.mk
+++ b/package/linux-tools/linux-tool-iio.mk.in
diff --git a/package/linux-tools/linux-tool-perf.mk b/package/linux-tools/linux-tool-perf.mk.in
index 16f3a58cc4..16f3a58cc4 100644
--- a/package/linux-tools/linux-tool-perf.mk
+++ b/package/linux-tools/linux-tool-perf.mk.in
diff --git a/package/linux-tools/linux-tool-selftests.mk b/package/linux-tools/linux-tool-selftests.mk.in
index c4e5bf0fea..c4e5bf0fea 100644
--- a/package/linux-tools/linux-tool-selftests.mk
+++ b/package/linux-tools/linux-tool-selftests.mk.in
diff --git a/package/linux-tools/linux-tools.mk b/package/linux-tools/linux-tools.mk
index 7fa8d194c6..ac4da59b17 100644
--- a/package/linux-tools/linux-tools.mk
+++ b/package/linux-tools/linux-tools.mk
@@ -10,15 +10,14 @@
#
# So, all tools refer to $(LINUX_DIR) instead of $(@D).
-# Note: we need individual tools .mk files to be included *before* this one
-# to guarantee that each tool has a chance to register itself before we build
-# the list of build and install hooks, below.
-#
-# This is currently guaranteed by the naming of each file:
-# - they get included by the top-level Makefile, with $(sort $(wildcard ...))
-# - make's $(sort) function will aways sort in the C locale
-# - the files names correctly sort out in the C locale so that each tool's
-# .mk file is included before this one.
+# Note: we need individual tools makefiles to be included *before* we build
+# the list of build and install hooks below to guarantee that each tool has
+# a chance to register itself once, and only once. Therefore, the makefiles
+# are named linux-tool-*.mk.in, so they won't be picked up by the top-level
+# Makefile, but can be included here, guaranteeing the single inclusion and
+# the proper ordering.
+
+include $(sort $(wildcard package/linux-tools/*.mk.in))
# We only need the kernel to be extracted, not actually built
LINUX_TOOLS_PATCH_DEPENDENCIES = linux