summaryrefslogtreecommitdiff
path: root/package/azure-iot-sdk-c
diff options
context:
space:
mode:
Diffstat (limited to 'package/azure-iot-sdk-c')
-rw-r--r--package/azure-iot-sdk-c/azure-iot-sdk-c.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/azure-iot-sdk-c/azure-iot-sdk-c.mk b/package/azure-iot-sdk-c/azure-iot-sdk-c.mk
index 504929aee6..3618e591a9 100644
--- a/package/azure-iot-sdk-c/azure-iot-sdk-c.mk
+++ b/package/azure-iot-sdk-c/azure-iot-sdk-c.mk
@@ -4,7 +4,7 @@
#
################################################################################
-AZURE_IOT_SDK_C_VERSION = 2018-03-16
+AZURE_IOT_SDK_C_VERSION = 2018-12-13
AZURE_IOT_SDK_C_SITE = https://github.com/Azure/azure-iot-sdk-c
AZURE_IOT_SDK_C_SITE_METHOD = git
AZURE_IOT_SDK_C_GIT_SUBMODULES = YES
@@ -14,6 +14,11 @@ AZURE_IOT_SDK_C_INSTALL_STAGING = YES
AZURE_IOT_SDK_C_DEPENDENCIES = libxml2 openssl libcurl util-linux
AZURE_IOT_SDK_C_CONF_OPTS = -Dskip_samples=ON
+# When cross-compiling, CMake doesn't internally pass any
+# CMAKE_SYSTEM_VERSION, so pass a dummy version to make the c-utility
+# WIN32 test happy.
+AZURE_IOT_SDK_C_CONF_OPTS += -DCMAKE_SYSTEM_VERSION=1.0
+
# The project only supports building one kind of library.
# Further the install target installs the wrong files, so we do it here:
ifeq ($(BR2_STATIC_LIBS),y)