summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index d88060e09c..4f4f80239e 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -351,6 +351,9 @@ define LINUX_INSTALL_HOST_TOOLS
# Installing dtc (device tree compiler) as host tool, if selected
if grep -q "CONFIG_DTC=y" $(@D)/.config; then \
$(INSTALL) -D -m 0755 $(@D)/scripts/dtc/dtc $(HOST_DIR)/usr/bin/linux-dtc ; \
+ if [ ! -e $(HOST_DIR)/usr/bin/dtc ]; then \
+ ln -sf linux-dtc $(HOST_DIR)/usr/bin/dtc ; \
+ fi \
fi
endef