summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Config.in11
-rw-r--r--package/Makefile.in3
2 files changed, 14 insertions, 0 deletions
diff --git a/Config.in b/Config.in
index 0002df5176..037ea2265b 100644
--- a/Config.in
+++ b/Config.in
@@ -527,6 +527,17 @@ config BR2_OPTIMIZE_S
-ftree-vect-loop-version
This is the default.
+config BR2_OPTIMIZE_FAST
+ bool "optimize for fast"
+ depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_6
+ help
+ Optimize for fast. Disregard strict standards
+ compliance. -Ofast enables all -O3 optimizations. It also
+ enables optimizations that are not valid for all
+ standard-compliant programs. It turns on -ffast-math and the
+ Fortran-specific -fstack-arrays, unless -fmax-stack-var-size
+ is specified, and -fno-protect-parens.
+
endchoice
config BR2_GOOGLE_BREAKPAD_ENABLE
diff --git a/package/Makefile.in b/package/Makefile.in
index e387ce67fe..828e12e7d7 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -128,6 +128,9 @@ endif
ifeq ($(BR2_OPTIMIZE_S),y)
TARGET_OPTIMIZATION = -Os
endif
+ifeq ($(BR2_OPTIMIZE_FAST),y)
+TARGET_OPTIMIZATION = -Ofast
+endif
ifeq ($(BR2_DEBUG_1),y)
TARGET_DEBUGGING = -g1
endif