summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Config.in12
-rw-r--r--support/dependencies/dependencies.mk6
2 files changed, 18 insertions, 0 deletions
diff --git a/Config.in b/Config.in
index f965e9d6d8..d58d8dc04a 100644
--- a/Config.in
+++ b/Config.in
@@ -677,6 +677,18 @@ config BR2_COMPILER_PARANOID_UNSAFE_PATH
and external toolchain backends (through the toolchain
wrapper).
+config BR2_FORCE_HOST_BUILD
+ bool "Force the building of host dependencies"
+ help
+ Build all available host dependencies, even if they are
+ already installed on the system.
+
+ This option can be used to ensure that the download cache of
+ source archives for packages remain consistent between
+ different build hosts.
+
+ This option will increase build time.
+
config BR2_REPRODUCIBLE
bool "Make the build reproducible (experimental)"
# SOURCE_DATE_EPOCH support in toolchain-wrapper requires GCC 4.4
diff --git a/support/dependencies/dependencies.mk b/support/dependencies/dependencies.mk
index 563574d6ad..4fac5c731b 100644
--- a/support/dependencies/dependencies.mk
+++ b/support/dependencies/dependencies.mk
@@ -5,6 +5,11 @@
#
################################################################################
+ifeq ($(BR2_FORCE_HOST_BUILD),y)
+# ignore all available host packages
+define suitable-host-package
+endef
+else
# suitable-host-pkg: calls check-host-$(1).sh shell script. Parameter (2)
# can be the candidate to be checked. If not present, the check-host-$(1).sh
# script should use 'which' to find a candidate. The script should return
@@ -12,6 +17,7 @@
define suitable-host-package
$(shell support/dependencies/check-host-$(1).sh $(2))
endef
+endif
# host utilities needs host-tar to extract the source code tarballs, so
# ensure check-host-tar.mk is included before the rest
include support/dependencies/check-host-tar.mk