summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/pseudo/pseudo.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/pseudo/pseudo.mk b/package/pseudo/pseudo.mk
index 314fa820c5..2137a37806 100644
--- a/package/pseudo/pseudo.mk
+++ b/package/pseudo/pseudo.mk
@@ -12,4 +12,12 @@ PSEUDO_SITE_METHOD = git
PSEUDO_LICENSE = LGPLv2.1
PSEUDO_LICENSE_FILES = COPYING
+HOST_PSEUDO_DEPENDENCIES = host-sqlite
+
+# configure script is not generated by autoconf, so passing --libdir
+# is necessary, even if the infrastructure passes --prefix already.
+HOST_PSEUDO_CONF_OPTS = \
+ --libdir=$(HOST_DIR)/usr/lib \
+ --with-sqlite=$(HOST_DIR)/usr
+
$(eval $(host-autotools-package))