summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorEd Blake <ed.blake@sondrel.com>2019-03-26 12:30:45 +0000
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2019-03-26 20:17:21 +0100
commit9c808710f6f0be9d7923d937768d7da8461666cb (patch)
tree637b0d9e66b814450629f149922499ed30825e13 /toolchain
parent529fef57f6f46201ba16349b49c0a65ceccc4c25 (diff)
toolchain-external: introduce BR2_TOOLCHAIN_HAS_OPENMP
Add new BR2_TOOLCHAIN_HAS_OPENMP option for toolchains with OpenMP support. Signed-off-by: Ed Blake <ed.blake@sondrel.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Config.in3
-rw-r--r--toolchain/toolchain-external/pkg-toolchain-external.mk4
2 files changed, 7 insertions, 0 deletions
diff --git a/toolchain/Config.in b/toolchain/Config.in
index 3f297f6b43..552220123f 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -168,6 +168,9 @@ config BR2_TOOLCHAIN_HAS_SSP
config BR2_TOOLCHAIN_HAS_UCONTEXT
bool
+config BR2_TOOLCHAIN_HAS_OPENMP
+ bool
+
config BR2_TOOLCHAIN_SUPPORTS_PIE
bool
diff --git a/toolchain/toolchain-external/pkg-toolchain-external.mk b/toolchain/toolchain-external/pkg-toolchain-external.mk
index db3570d96f..747837fdc6 100644
--- a/toolchain/toolchain-external/pkg-toolchain-external.mk
+++ b/toolchain/toolchain-external/pkg-toolchain-external.mk
@@ -144,6 +144,10 @@ TOOLCHAIN_EXTERNAL_LIBS += libquadmath.so*
endif
endif
+ifeq ($(BR2_TOOLCHAIN_HAS_OPENMP),y)
+TOOLCHAIN_EXTERNAL_LIBS += libgomp.so.*
+endif
+
TOOLCHAIN_EXTERNAL_LIBS += $(call qstrip,$(BR2_TOOLCHAIN_EXTRA_EXTERNAL_LIBS))