summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorMark Corbin <mark.corbin@embecosm.com>2018-09-12 11:22:54 +0100
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-09-23 23:42:41 +0200
commit9b3d52b4008abacc4ea4867e0fe4e68ed32b1920 (patch)
treea4f6a1c4ef524a16cb6cb9fa818e112d994d10d3 /toolchain
parent03e2bad8687c882b85d213fff9354c788b5c1bf2 (diff)
arch: add support for RISC-V 64-bit (riscv64) architecture
This enables a riscv64 system to be built with a Buildroot generated toolchain (gcc >= 7.x, binutils >= 2.30, glibc only). This configuration has been used to successfully build a qemu-bootable riscv-linux-4.15 kernel (https://github.com/riscv/riscv-linux.git). Signed-off-by: Mark Corbin <mark.corbin@embecosm.com> [Thomas: - simplify arch.mk.riscv by directly setting GCC_TARGET_ARCH - simplify glibc.mk changes by using GLIBC_CONF_ENV.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/toolchain-buildroot/Config.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/toolchain/toolchain-buildroot/Config.in b/toolchain/toolchain-buildroot/Config.in
index 75e8191f46..7d9428c70e 100644
--- a/toolchain/toolchain-buildroot/Config.in
+++ b/toolchain/toolchain-buildroot/Config.in
@@ -46,14 +46,16 @@ config BR2_TOOLCHAIN_BUILDROOT_GLIBC
BR2_aarch64_be || BR2_i386 || BR2_mips || \
BR2_mipsel || BR2_mips64 || BR2_mips64el|| \
BR2_powerpc || BR2_powerpc64 || BR2_powerpc64le || \
- BR2_sh || BR2_sparc64 || BR2_x86_64 || \
- BR2_microblaze || BR2_nios2 || BR2_archs38
+ BR2_riscv || BR2_sh || BR2_sparc64 || \
+ BR2_x86_64 || BR2_microblaze || BR2_nios2 || \
+ BR2_archs38
depends on BR2_USE_MMU
depends on !BR2_STATIC_LIBS
depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_2
depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_10 || !BR2_powerpc64le
depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_5 || !BR2_MIPS_NAN_2008
depends on !BR2_powerpc_SPE
+ depends on BR2_RISCV_ISA_RVA || !BR2_riscv
select BR2_TOOLCHAIN_USES_GLIBC
# our glibc.mk enables RPC support
select BR2_TOOLCHAIN_HAS_NATIVE_RPC