summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2017-07-18 19:25:32 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-07-22 22:33:38 +0200
commitb07ccc47cb511b877e6e7bb45c511e0646cb5528 (patch)
treeef75bd79434e25917854e4994567bde9640927aa /system
parent2de968f03a76c3feb5c7693cfc05a6342fcc12ae (diff)
system: move setting getty to the corresponding init systems
Currently, setting the getty is done: - by the skeleton package when the init system is either busybox or sysvinit; - by the systemd package when the init system is systemd; both by registering a target-finalize hook. This is not very consistent. Move setting the getty out of the skeleton and into the package that provides the init system, by registering a per-package target-fialize hook. This offloads yet a bit more out of the skeleton, so that it is easier to properly separate the skeletons for the various init systems. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'system')
-rw-r--r--system/system.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/system/system.mk b/system/system.mk
index cab5c1df5d..7b843dad8e 100644
--- a/system/system.mk
+++ b/system/system.mk
@@ -22,6 +22,12 @@
# - SYSTEM_LIB_SYMLINK
# create the appropriate /lib{32,64} symlinks
#
+# - SYSTEM_GETTY_PORT
+# - SYSTEM_GETTY_BAUDRATE
+# - SYSTEM_GETTY_TERM
+# - SYSTEM_GETTY_OPTIONS
+# the un-quoted getty setting
+#
# This function handles the merged or non-merged /usr cases
ifeq ($(BR2_ROOTFS_MERGED_USR),y)
@@ -60,3 +66,8 @@ define SYSTEM_LIB_SYMLINK
ln -snf lib $(1)/usr/lib32
endef
endif
+
+SYSTEM_GETTY_PORT = $(call qstrip,$(BR2_TARGET_GENERIC_GETTY_PORT))
+SYSTEM_GETTY_BAUDRATE = $(call qstrip,$(BR2_TARGET_GENERIC_GETTY_BAUDRATE))
+SYSTEM_GETTY_TERM = $(call qstrip,$(BR2_TARGET_GENERIC_GETTY_TERM))
+SYSTEM_GETTY_OPTIONS = $(call qstrip,$(BR2_TARGET_GENERIC_GETTY_OPTIONS))