summaryrefslogtreecommitdiff
path: root/support/testing/tests/download/br2-external/git-refs/package/git-sha1-reachable-by-tag/git-sha1-reachable-by-tag.mk
diff options
context:
space:
mode:
authorRicardo Martincoski <ricardo.martincoski@datacom.ind.br>2018-05-11 23:58:31 -0300
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2019-02-06 10:57:26 +0100
commited3cda38cd533ffae68258ca5586c3df4789c120 (patch)
tree6b3e78e26708dbdf3d78586b7dc5bc5cc2914243 /support/testing/tests/download/br2-external/git-refs/package/git-sha1-reachable-by-tag/git-sha1-reachable-by-tag.mk
parentc6386be05b814dbfda94b0a00b164f87dbe24796 (diff)
testing/tests/download: test git tag
Add a tag to the static repo and check on the git refs test case the download of a git package: - with the name of a tag as version; - with the sha1 of a tag itself as version; - with the partial sha1 of a tag itself as version; - with the sha1 of a commit pointed by a tag as version; - with the partial sha1 of a commit pointed by a tag as version; - with the sha1 of a commit reachable only by a tag as version; - with the partial sha1 of a commit reachable only by a tag as version. Signed-off-by: Ricardo Martincoski <ricardo.martincoski@datacom.ind.br> Cc: Arnout Vandecappelle <arnout@mind.be> Tested-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Diffstat (limited to 'support/testing/tests/download/br2-external/git-refs/package/git-sha1-reachable-by-tag/git-sha1-reachable-by-tag.mk')
-rw-r--r--support/testing/tests/download/br2-external/git-refs/package/git-sha1-reachable-by-tag/git-sha1-reachable-by-tag.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/support/testing/tests/download/br2-external/git-refs/package/git-sha1-reachable-by-tag/git-sha1-reachable-by-tag.mk b/support/testing/tests/download/br2-external/git-refs/package/git-sha1-reachable-by-tag/git-sha1-reachable-by-tag.mk
new file mode 100644
index 0000000000..b5fde7b586
--- /dev/null
+++ b/support/testing/tests/download/br2-external/git-refs/package/git-sha1-reachable-by-tag/git-sha1-reachable-by-tag.mk
@@ -0,0 +1,11 @@
+################################################################################
+#
+# git-sha1-reachable-by-tag
+#
+################################################################################
+
+GIT_SHA1_REACHABLE_BY_TAG_VERSION = 46bae5b639e5a18e2cc4dc508f080d566baeff59
+GIT_SHA1_REACHABLE_BY_TAG_SITE = git://localhost:$(GITREMOTE_PORT_NUMBER)/repo.git
+GIT_SHA1_REACHABLE_BY_TAG_LICENSE_FILES = file
+
+$(eval $(generic-package))