summaryrefslogtreecommitdiff
path: root/package/xmlstarlet
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@gmail.com>2017-09-02 22:07:41 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-09-02 23:05:09 +0200
commit0d8247947eb756a8505b5930c66b034e58b10df0 (patch)
treea714c789fcd7a8dd6425a0917253ea157296ea95 /package/xmlstarlet
parent110a76baa085b1f164a1a0a8801e2258ef15f916 (diff)
package/xmlstarlet: fix host build
Provide the path to HOST_DIR for libxml, libxslt and libiconv like for the target variant to avoid a build issue on host where /bin is a symlink to /usr/bin. Indeed, the configure script use a custom m4 macro XSTAR_LIB_CHECK to find xml2-config: XSTAR_LIB_CHECK([LIBXML], [xml2-config]) This macro come from a local m4 file m4/xstar-check-libs.m4 where it use: AC_PATH_PROG(LIBXXX()_CONFIG, xxx_config(), [], [$LIBXXX()_PREFIX/bin$PATH_SEPARATOR$PATH] Since no prefix seems to be defined by $LIBXXX()_PREFIX, AC_PATH_PROG look by itself at /bin/ for xml2-config. So the PATH variable set by Buildroot containing HOST_DIR/bin is ignored. The wrong xml2-config is used during the build and the build fail when no xml2 headers are installed on the host. Fixes: src/xml_C14N.c:12:31: fatal errorĀ : libxml/xmlversion.h : No such file or directory #include <libxml/xmlversion.h> ^ In file included from src/trans.c:4:0: src/trans.h:32:30: fatal errorĀ : libxml/xmlmemory.h : No such file or directory #include <libxml/xmlmemory.h> Signed-off-by: Romain Naour <romain.naour@gmail.com> Cc: Bernd Kuhls <bernd.kuhls@t-online.de> [Thomas: remove french messages from the commit log, drop --with-libiconv-prefix option, since we don't have a libiconv dependency for the host.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/xmlstarlet')
-rw-r--r--package/xmlstarlet/xmlstarlet.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/xmlstarlet/xmlstarlet.mk b/package/xmlstarlet/xmlstarlet.mk
index 9920dcfc70..1d748dc594 100644
--- a/package/xmlstarlet/xmlstarlet.mk
+++ b/package/xmlstarlet/xmlstarlet.mk
@@ -26,5 +26,9 @@ endif
HOST_XMLSTARLET_DEPENDENCIES += host-libxml2 host-libxslt
+HOST_XMLSTARLET_CONF_OPTS += \
+ --with-libxml-prefix=$(HOST_DIR)/usr \
+ --with-libxslt-prefix=$(HOST_DIR)/usr
+
$(eval $(autotools-package))
$(eval $(host-autotools-package))