summaryrefslogtreecommitdiff
path: root/package/webkitgtk
diff options
context:
space:
mode:
authorAdrián Pérez de Castro <aperez@igalia.com>2017-07-29 16:18:44 +0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-07-29 15:34:35 +0200
commit9aceb8bfa8c39167b1c449301b7f00f16e4f816c (patch)
treeb68a0e33aea92b86590d983ff8e9eab22d3cd5be /package/webkitgtk
parent3e4efb30f3bf96cad33e2f8982d469803dded145 (diff)
webkitgtk: Allow building with BR2_PACKAGE_WEBKITGTK_MULTIMEDIA disabled
Explicitly pass "-DENABLE_MEDIA_STREAM=OFF" to CMake, to workaround a missing feature dependency in the WebKitGTK+ build files. Related upstream bug: https://bugs.webkit.org/show_bug.cgi?id=174940 Signed-off-by: Adrian Perez de Castro <aperez@igalia.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/webkitgtk')
-rw-r--r--package/webkitgtk/webkitgtk.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/webkitgtk/webkitgtk.mk b/package/webkitgtk/webkitgtk.mk
index b200d23262..e30d07fc1d 100644
--- a/package/webkitgtk/webkitgtk.mk
+++ b/package/webkitgtk/webkitgtk.mk
@@ -40,9 +40,13 @@ WEBKITGTK_CONF_OPTS += \
-DENABLE_WEB_AUDIO=ON
WEBKITGTK_DEPENDENCIES += gstreamer1 gst1-libav gst1-plugins-base gst1-plugins-good
else
+# ENABLE_MEDIA_STREAM has to be explicitly disabled because there is a missing
+# feature dependency in the WebKitGTK+ CMake files. This can be removed once
+# https://bugs.webkit.org/show_bug.cgi?id=174940 makes it into a release.
WEBKITGTK_CONF_OPTS += \
-DENABLE_VIDEO=OFF \
- -DENABLE_WEB_AUDIO=OFF
+ -DENABLE_WEB_AUDIO=OFF \
+ -DENABLE_MEDIA_STREAM=OFF
endif
# Only one target platform can be built, assume X11 > Wayland