summaryrefslogtreecommitdiff
path: root/package/transmission/0003-fix-utp-include.patch
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2018-05-02 08:05:37 +0200
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-05-20 15:48:36 +0200
commitf451bed9c45c97cf6000e6935ab430102716b63d (patch)
tree3576730313385d8ecdb49d8c9a7bfa165ca6c36b /package/transmission/0003-fix-utp-include.patch
parent8e5837cae71a2676d9c74017e6b1ef23d99ab51c (diff)
package/transmission: bump version to 2.9.4
Removed patch 0003, a different fix was committed upstream: https://github.com/transmission/transmission/commit/b21a6140e963491f146293c9b0a2863a9ae99ad3 Renumbered remaining patches. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/transmission/0003-fix-utp-include.patch')
-rw-r--r--package/transmission/0003-fix-utp-include.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/package/transmission/0003-fix-utp-include.patch b/package/transmission/0003-fix-utp-include.patch
new file mode 100644
index 0000000000..db8b5ab39b
--- /dev/null
+++ b/package/transmission/0003-fix-utp-include.patch
@@ -0,0 +1,46 @@
+Fix compilation when using system libminiupnpc with libutp disabled
+
+If transmission uses its own copy of libminiupnpc in third-party/ then
+the configure script adds that path to CFLAGS:
+https://trac.transmissionbt.com/browser/trunk/configure.ac#L455
+
+This path is also added if transmission uses its own copy of libutp:
+https://trac.transmissionbt.com/browser/trunk/configure.ac#L349
+
+But if a system-provided libminiupnpc is used and utp-support is
+disabled using --disable-utp the result is a build error, detected by
+buildroot autobuilders:
+http://autobuild.buildroot.net/results/b79/b79e51140cb0320554a58ce59dcb33f53cd9211a/build-end.log
+
+net.c:40:24: fatal error: libutp/utp.h: No such file or directory
+
+Patch proposed by Yann E. MORIN:
+http://lists.busybox.net/pipermail/buildroot/2016-July/167896.html
+
+Patch sent upstream: https://trac.transmissionbt.com/ticket/6163
+
+Signed-off-by: Bernd Kuhls <berndkuhls@hotmail.com>
+
+diff -uNr transmission-2.92.org/configure.ac transmission-2.92/configure.ac
+--- transmission-2.92.org/configure.ac 2016-03-06 21:23:45.336198393 +0100
++++ transmission-2.92/configure.ac 2016-07-31 12:13:40.921660078 +0200
+@@ -358,6 +358,10 @@
+ else
+ AC_MSG_ERROR("Unable to build uTP support -- C++ compiler not found")
+ fi
++else
++ # For the system libminiupnpc with UTC disabled,
++ # point to our bundled UTP headers
++ LIBUTP_CFLAGS="-I\$(top_srcdir)/third-party/"
+ fi
+ AC_SUBST(LIBUTP_CFLAGS)
+ AC_SUBST(LIBUTP_LIBS)
+@@ -457,7 +461,7 @@
+ LIBUPNP_LIBS_QT="\$\${TRANSMISSION_TOP}/third-party/miniupnp/libminiupnp.a"
+ else
+ AC_DEFINE([SYSTEM_MINIUPNP])
+- LIBUPNP_CFLAGS=""
++ LIBUPNP_CFLAGS="${LIBUTP_CFLAGS}"
+ LIBUPNP_LIBS="-lminiupnpc"
+ LIBUPNP_LIBS_QT="-lminiupnpc"
+ fi