summaryrefslogtreecommitdiff
path: root/package/ti-gfx
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-09-03 14:54:21 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-09-04 13:16:58 +0200
commit727bae0245f306332c710c9c020c59bd975d8711 (patch)
treef5e23a9a79545368d0b86192b1ebfaae6891bfa5 /package/ti-gfx
parent2e95747ab9b6b0bf97007ce2733321c90462249a (diff)
packages: ensure linux supports modules even when not using kernel-module
Some packages build kernel modules without using the kernel-module infra (because they use custom build systems); they do not automatically get the kernel to support modules which is ensured when using the infra. It must be done manually for all those packages, whenever they are enabled. Note: the nvidia-driver case does not need the ifeq-block other packages use, because it is already enclosed in a more stringent ifeq-block. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Peter Korsgaard <jacmet@uclibc.org> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: NoƩ Rubinstein <nrubinstein@aldebaran.com> Cc: Jan Viktorin <viktorin@rehivetech.com> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Jan Viktorin <viktorin@rehivetech.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/ti-gfx')
-rw-r--r--package/ti-gfx/ti-gfx.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/ti-gfx/ti-gfx.mk b/package/ti-gfx/ti-gfx.mk
index 5339387c98..d23985f9a8 100644
--- a/package/ti-gfx/ti-gfx.mk
+++ b/package/ti-gfx/ti-gfx.mk
@@ -21,6 +21,13 @@ TI_GFX_LICENSE_FILES = TSPA.txt
TI_GFX_INSTALL_STAGING = YES
TI_GFX_DEPENDENCIES = linux
+
+# We're building a kernel module without using the kernel-module infra,
+# so we need to tell we want module support in the kernel
+ifeq ($(BR2_PACKAGE_TI_GFX),y)
+LINUX_NEEDS_MODULES = y
+endif
+
TI_GFX_PROVIDES = libegl libgles powervr
ifeq ($(BR2_PACKAGE_TI_GFX_ES3),y)