summaryrefslogtreecommitdiff
path: root/package/shairport-sync
diff options
context:
space:
mode:
authorJörg Krause <joerg.krause@embedded.rocks>2018-09-09 11:43:17 +0200
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-09-10 17:34:44 +0200
commitac4bca24adf2a50d1d9ac858cec26fdcd39578ef (patch)
tree446a6bafff172649e1db56b4ae4ac6672717a7d8 /package/shairport-sync
parentbbedf882e5d756363b4fda253cfe2a3c7501d081 (diff)
shairport-sync: add upstream patch to fix soxr configure issue
Commit e047dee241fe0660d92311a124757065c6c4c93d adds an upstream patch to fix a build issue with soxr. The patch also adds detecting soxr using pkg-config. Upstream detected an config issue [1], where the resulting binary lacks soxr support, although libsoxr was correctly detected. This patch adds a define for `HAVE_LIBSOXR` when using pkg-config. Backported from: cd6a99a7cfde1c5e1c1cc74ee6a77041bb4012d9 [1] https://github.com/mikebrady/shairport-sync/issues/740 Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/shairport-sync')
-rw-r--r--package/shairport-sync/0002-Include-a-definition-of-HAVE_LIBSOXR-with-using-pkg_config.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/package/shairport-sync/0002-Include-a-definition-of-HAVE_LIBSOXR-with-using-pkg_config.patch b/package/shairport-sync/0002-Include-a-definition-of-HAVE_LIBSOXR-with-using-pkg_config.patch
new file mode 100644
index 0000000000..66ce961ab1
--- /dev/null
+++ b/package/shairport-sync/0002-Include-a-definition-of-HAVE_LIBSOXR-with-using-pkg_config.patch
@@ -0,0 +1,35 @@
+From cd6a99a7cfde1c5e1c1cc74ee6a77041bb4012d9 Mon Sep 17 00:00:00 2001
+From: Mike Brady <mikebrady@eircom.net>
+Date: Sat, 8 Sep 2018 15:06:18 +0100
+Subject: [PATCH] Include a definition of HAVE_LIBSOXR with using pkg_config
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Commit e047dee241fe0660d92311a124757065c6c4c93d adds an upstream patch
+to fix a build issue with soxr. The patch also adds detecting soxr
+using pkg-config. Upstream detected a config issue [1], where the
+resulting binary lacks soxr support, although libsoxr was correctly
+detected.
+
+Backported from: cd6a99a7cfde1c5e1c1cc74ee6a77041bb4012d9
+
+Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
+---
+ configure.ac | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/configure.ac b/configure.ac
+index ceec4af..690a774 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -180,6 +180,7 @@ AC_ARG_WITH(soxr, [ --with-soxr = choose libsoxr for high-quality interpolation
+ PKG_CHECK_MODULES(
+ [SOXR], [soxr],
+ [LIBS="${SOXR_LIBS} ${LIBS}"])
++ AC_DEFINE([HAVE_LIBSOXR],[1],[Define to 1 if you are including support for soxr interpolation])
+ else
+ AC_CHECK_LIB([avutil],[av_get_cpu_flags])
+ if test "x${ac_cv_lib_avutil_av_get_cpu_flags}" = xyes ; then
+--
+2.18.0