summaryrefslogtreecommitdiff
path: root/package/shairport-sync
diff options
context:
space:
mode:
authorJörg Krause <joerg.krause@embedded.rocks>2015-09-08 08:49:43 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-09-20 15:05:40 +0200
commit539169dac45be1218a63d3d0cfee231b828e3b6a (patch)
tree9b97bbc0c609bb1e775bf8496834402a77848408 /package/shairport-sync
parent421b938c9fee3f5462300588dd6af05cf1eb25ed (diff)
package/shairport-sync: bump to version 2.4
Version 2.4 of shairport-sync introduces new optional features (metadata, stdout, pipe) which we enable by default. The impact on the binary size is about 18 kB (110 kB vs 92 kB) for an ARM target. Also add a new dependency to libconfig and install the default config script. Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/shairport-sync')
-rw-r--r--package/shairport-sync/Config.in1
-rw-r--r--package/shairport-sync/shairport-sync.mk11
2 files changed, 9 insertions, 3 deletions
diff --git a/package/shairport-sync/Config.in b/package/shairport-sync/Config.in
index c1d81a7e2a..c558a64c5b 100644
--- a/package/shairport-sync/Config.in
+++ b/package/shairport-sync/Config.in
@@ -4,6 +4,7 @@ config BR2_PACKAGE_SHAIRPORT_SYNC
depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
select BR2_PACKAGE_ALSA_LIB
select BR2_PACKAGE_ALSA_LIB_MIXER
+ select BR2_PACKAGE_LIBCONFIG
select BR2_PACKAGE_LIBDAEMON
select BR2_PACKAGE_POLARSSL if !BR2_PACKAGE_OPENSSL
select BR2_PACKAGE_POPT
diff --git a/package/shairport-sync/shairport-sync.mk b/package/shairport-sync/shairport-sync.mk
index 881cceda2c..dc36c0ea0d 100644
--- a/package/shairport-sync/shairport-sync.mk
+++ b/package/shairport-sync/shairport-sync.mk
@@ -4,17 +4,20 @@
#
################################################################################
-SHAIRPORT_SYNC_VERSION = 2.2.4
+SHAIRPORT_SYNC_VERSION = 2.4
SHAIRPORT_SYNC_SITE = $(call github,mikebrady,shairport-sync,$(SHAIRPORT_SYNC_VERSION))
SHAIRPORT_SYNC_LICENSE = MIT, BSD-3c
SHAIRPORT_SYNC_LICENSE_FILES = LICENSES
-SHAIRPORT_SYNC_DEPENDENCIES = alsa-lib libdaemon popt host-pkgconf
+SHAIRPORT_SYNC_DEPENDENCIES = alsa-lib libconfig libdaemon popt host-pkgconf
# Touching configure.ac with the patches
SHAIRPORT_SYNC_AUTORECONF = YES
-SHAIRPORT_SYNC_CONF_OPTS = --with-alsa
+SHAIRPORT_SYNC_CONF_OPTS = --with-alsa \
+ --with-metadata \
+ --with-pipe \
+ --with-stdout
# Avahi or tinysvcmdns (shaiport-sync bundles its own version of tinysvcmdns).
# Avahi support needs libavahi-client, which is built by avahi if avahi-daemon
@@ -45,6 +48,8 @@ endif
define SHAIRPORT_SYNC_INSTALL_TARGET_CMDS
$(INSTALL) -D -m 0755 $(@D)/shairport-sync \
$(TARGET_DIR)/usr/bin/shairport-sync
+ $(INSTALL) -D -m 0644 $(@D)/scripts/shairport-sync.conf \
+ $(TARGET_DIR)/etc/shairport-sync.conf
endef
define SHAIRPORT_SYNC_INSTALL_INIT_SYSV