summaryrefslogtreecommitdiff
path: root/package/python3/0017-Add-an-option-to-disable-the-tk-module.patch
diff options
context:
space:
mode:
authorAndrey Smirnov <andrew.smirnov@gmail.com>2017-03-23 08:21:12 -0700
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-03-25 15:18:49 +0100
commitd2afa01f76ce2c7610286103340048d953b27e45 (patch)
tree5fffb2d070841068df535c03449c11a15e43318e /package/python3/0017-Add-an-option-to-disable-the-tk-module.patch
parentf48f1a89a0c598ebefd2643af3ad6aff981e291c (diff)
python3: Bump version to 3.6.1
Update all appropriate version numbers as well as SHAs and MD5s as well as repbasing BR's patches on top of 3.6.1 codebase (new github repo tree, v3.6.1 tag was used). Note that patch: [PATCH] Change the install location of _sysconfigdata.py was dropped due to the fact taht build system now adds platform specific suffix to sysconfigdata's name, so each platform's file should have a unique name and distutils now allows to specify which sysconfigdata is used via _PYTHON_SYSCONFIGDATA_NAME see: https://github.com/python/cpython/commit/c4b53afce491142b80b228a21a05de5dcfd8d36f https://github.com/python/cpython/commit/92dec548ff1494b86f08bd3753ca91a9330b4ea9 and patches: [PATCH] distutils/sysconfig: use sysconfigdata [PATCH] setup.py: do not add invalid header locations [PATCH] Do not harcode invalid path to ncursesw headers was dropped since it looks like it made it's way upstream, see: https://github.com/python/cpython/commit/409482251b06fe75c4ee56e85ffbb4b23d934159 https://github.com/python/cpython/commit/1351c31aa9651b278d7ef8ec79af3b646a520235 https://github.com/python/cpython/commit/e13c3201fb66c4c211b4ebb7604d1435bedc1015 respectively. Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python3/0017-Add-an-option-to-disable-the-tk-module.patch')
-rw-r--r--package/python3/0017-Add-an-option-to-disable-the-tk-module.patch73
1 files changed, 73 insertions, 0 deletions
diff --git a/package/python3/0017-Add-an-option-to-disable-the-tk-module.patch b/package/python3/0017-Add-an-option-to-disable-the-tk-module.patch
new file mode 100644
index 0000000000..925eb82d4b
--- /dev/null
+++ b/package/python3/0017-Add-an-option-to-disable-the-tk-module.patch
@@ -0,0 +1,73 @@
+From 4fc4260e66f8b004f14feb332c57a2d8fdd305de Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Wed, 22 Feb 2017 17:23:42 -0800
+Subject: [PATCH] Add an option to disable the tk module
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Signed-off-by: Samuel Martin <s.martin49@gmail.com>
+[ Andrey Smirnov: ported to Python 3.6 ]
+Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
+---
+ Makefile.pre.in | 11 ++++++++---
+ configure.ac | 9 +++++++++
+ 2 files changed, 17 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.pre.in b/Makefile.pre.in
+index 3907f92..93ef34d 100644
+--- a/Makefile.pre.in
++++ b/Makefile.pre.in
+@@ -1196,7 +1196,7 @@ maninstall: altmaninstall
+ # Install the library
+ XMLLIBSUBDIRS= xml xml/dom xml/etree xml/parsers xml/sax
+
+-LIBSUBDIRS= tkinter site-packages \
++LIBSUBDIRS= site-packages \
+ asyncio \
+ collections concurrent concurrent/futures encodings \
+ email email/mime \
+@@ -1213,8 +1213,7 @@ LIBSUBDIRS= tkinter site-packages \
+ venv venv/scripts venv/scripts/common venv/scripts/posix \
+ curses
+
+-TESTSUBDIRS= tkinter/test tkinter/test/test_tkinter \
+- tkinter/test/test_ttk test \
++TESTSUBDIRS= test \
+ test/audiodata \
+ test/capath test/data \
+ test/cjkencodings test/decimaltestdata test/xmltestdata \
+@@ -1260,6 +1259,12 @@ TESTSUBDIRS= tkinter/test tkinter/test/test_tkinter \
+ test/test_tools test/test_warnings test/test_warnings/data \
+ unittest/test unittest/test/testmock
+
++ifeq (@TK@,yes)
++LIBSUBDIRS += tkinter
++TESTSUBDIRS += tkinter/test tkinter/test/test_tkinter \
++ tkinter/test/test_ttk
++endif
++
+ ifeq (@LIB2TO3@,yes)
+ LIBSUBDIRS += lib2to3 lib2to3/fixes lib2to3/pgen2
+ TESTSUBDIRS += lib2to3/tests \
+diff --git a/configure.ac b/configure.ac
+index a30c45d..52887c9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -3090,6 +3090,15 @@ if test "$SQLITE3" = "no" ; then
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
+ fi
+
++AC_SUBST(TK)
++AC_ARG_ENABLE(tk,
++ AS_HELP_STRING([--disable-tk], [disable tk]),
++ [ TK="${enableval}" ], [ TK=yes ])
++
++if test "$TK" = "no"; then
++ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _tkinter"
++fi
++
+ AC_SUBST(PYDOC)
+
+ AC_ARG_ENABLE(pydoc,
+--
+2.9.3
+