summaryrefslogtreecommitdiff
path: root/package/python-smbus-cffi
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2015-12-31 23:08:30 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-03 22:34:20 +0100
commit9d05cb121a93aa0501f4c7369881d304063c84da (patch)
treee1ddbbfe3f5c329f7efb07c443d4211f44e1363a /package/python-smbus-cffi
parentce726bae3150506174fd612318615a3be81224bc (diff)
python-smbus-cffi: new package
[Thomas: - fix license, it's GPLv2, not GPLv2+.] Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-smbus-cffi')
-rw-r--r--package/python-smbus-cffi/Config.in10
-rw-r--r--package/python-smbus-cffi/python-smbus-cffi.hash3
-rw-r--r--package/python-smbus-cffi/python-smbus-cffi.mk15
3 files changed, 28 insertions, 0 deletions
diff --git a/package/python-smbus-cffi/Config.in b/package/python-smbus-cffi/Config.in
new file mode 100644
index 0000000000..32f005c096
--- /dev/null
+++ b/package/python-smbus-cffi/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PYTHON_SMBUS_CFFI
+ bool "python-smbus-cffi"
+ select BR2_PACKAGE_PYTHON_CFFI
+ help
+ This Python module allows SMBus access through the I2C /dev
+ interface on Linux hosts. The host kernel must have I2C
+ support, I2C device interface support, and a bus adapter
+ driver.
+
+ https://github.com/bivab/smbus-cffi
diff --git a/package/python-smbus-cffi/python-smbus-cffi.hash b/package/python-smbus-cffi/python-smbus-cffi.hash
new file mode 100644
index 0000000000..1e28df99b7
--- /dev/null
+++ b/package/python-smbus-cffi/python-smbus-cffi.hash
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi?:action=show_md5&digest=f621c871bd658ee665751ad78e3b2df9, sha256 locally computed
+md5 f621c871bd658ee665751ad78e3b2df9 smbus-cffi-0.5.1.tar.gz
+sha256 fb4195aaabfc01586863f60d3190b5cb1bf8f12622fd597e23e48768dad6bde8 smbus-cffi-0.5.1.tar.gz
diff --git a/package/python-smbus-cffi/python-smbus-cffi.mk b/package/python-smbus-cffi/python-smbus-cffi.mk
new file mode 100644
index 0000000000..5fd9558e87
--- /dev/null
+++ b/package/python-smbus-cffi/python-smbus-cffi.mk
@@ -0,0 +1,15 @@
+################################################################################
+#
+# python-smbus-cffi
+#
+################################################################################
+
+PYTHON_SMBUS_CFFI_VERSION = 0.5.1
+PYTHON_SMBUS_CFFI_SOURCE = smbus-cffi-$(PYTHON_SMBUS_CFFI_VERSION).tar.gz
+PYTHON_SMBUS_CFFI_SITE = https://pypi.python.org/packages/source/s/smbus-cffi
+PYTHON_SMBUS_CFFI_SETUP_TYPE = setuptools
+PYTHON_SMBUS_CFFI_LICENSE = GPLv2
+PYTHON_SMBUS_CFFI_LICENSE_FILES = LICENSE
+PYTHON_SMBUS_CFFI_DEPENDENCIES = host-python-cffi
+
+$(eval $(python-package))