summaryrefslogtreecommitdiff
path: root/package/python-pyqt5
diff options
context:
space:
mode:
authorNaumann Andreas <ANaumann@ultratronik.de>2017-01-31 08:59:03 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-02-07 17:46:48 +0100
commitaa1c40ba3729b73618c28e82f89dbee82c34ff76 (patch)
treeb46bd339f12e4d82532f66d2aee86b0b95493e9f /package/python-pyqt5
parent61c8273e2357f6aab202f6c8653f85f21c3c4f7a (diff)
qt5: add choice between version 5.6.2 and 5.8.0
For 5.8.0 - add hashes - qt5 need C++11 compliant compiler since 5.7 ([1]) - use different licenses: since version 5.7 Qt removed the LGPL v2.1 option in favor of v3 with a different exception - qt5base: renamed library to EglFSDeviceIntegration ([2]) - qt5base: remove ras-pi patch, commit c0cc5052097c723d0331a7619d686af9eb93d33c fix it ([3]) - qt5base: remove 0007-eglfs-fix-eglfs_mali-compile-for-odroid-mali.patch (upstream committed [3b]) - qt5base: remove obsolete config-option -large ([4]) - qt5base: gstreamer support fully moved to qt5multimedia, so gstreamer related options are no longer passed ([5]) - add patch for python-pyqt5 to fix the build with Qt 5.8 - add tweak in libv4l to fix the build with Qt 5.8, originally provided by Peter Seiderer - add patch from Peter Seiderer fixing a build issue with freetype For 5.6.2 - moved patches to subdir, and renumber patches [1] http://blog.qt.io/blog/2016/06/16/qt-5-7-released/ [2] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=ec4eb4db61094179bc6a9ec26ec68fb710177053 [3] https://codereview.qt-project.org/#/c/167172/ [3b] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=f1b4bd4790860e1ff5afcec111a359bc3a91cfda [4] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=84d3a21c9efe7efb2cce6d3bd14af1f9580b1108 [5] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=7d4da559afb62a779b3d90a65fb679cb5433f203 Signed-off-by: Andreas Naumann <anaumann@ultratronik.de> Signed-off-by: Julien Corjon <corjon.j@ecagroup.com> Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com> [Thomas: - tweak commit log about GStreamer related changes, suggested by Arnout - move the gcc 4.8 dependency from the main qt5 option to just the qt5.8 selection, so that qt5.6 can still be built if gcc < 4.8 is used. Noticed by Arnout. - rename the options of the version selection to not include the version number itself so that we don't have to keep legacy symbols. Noticed by Arnout. - introduce changes to qt5quickcontrols2.mk needed to handle qt5.6 vs. qt5.8, borrowed from a later patch in the series. - add patch for python-pyqt5 to fix the build with Qt 5.8. - add fix to libv4l.mk from Peter Seiderer to fix the build with Qt 5.8. - renumber patches for 5.6.2, suggested by Arnout.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-pyqt5')
-rw-r--r--package/python-pyqt5/0003-remove-WindowOkButtonHint-and-WindowCancelButtonHint.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/package/python-pyqt5/0003-remove-WindowOkButtonHint-and-WindowCancelButtonHint.patch b/package/python-pyqt5/0003-remove-WindowOkButtonHint-and-WindowCancelButtonHint.patch
new file mode 100644
index 0000000000..146cce0348
--- /dev/null
+++ b/package/python-pyqt5/0003-remove-WindowOkButtonHint-and-WindowCancelButtonHint.patch
@@ -0,0 +1,27 @@
+From bb7cbdede46f72468bbb1b9bbefd43a1dbad21c0 Mon Sep 17 00:00:00 2001
+From: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
+Date: Mon, 30 Jan 2017 18:28:15 +0100
+Subject: [PATCH] remove WindowOkButtonHint and WindowCancelButtonHint from
+ qnamespace.sip as they are removed from qt5.8
+
+Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
+---
+ sip/QtCore/qnamespace.sip | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/sip/QtCore/qnamespace.sip b/sip/QtCore/qnamespace.sip
+index 2db83b7..559f410 100644
+--- a/sip/QtCore/qnamespace.sip
++++ b/sip/QtCore/qnamespace.sip
+@@ -209,8 +209,6 @@ namespace Qt
+ WindowContextHelpButtonHint,
+ WindowShadeButtonHint,
+ WindowStaysOnTopHint,
+- WindowOkButtonHint,
+- WindowCancelButtonHint,
+ WindowStaysOnBottomHint,
+ WindowCloseButtonHint,
+ MacWindowToolBarButtonHint,
+--
+2.7.4
+