summaryrefslogtreecommitdiff
path: root/package/powerpc-utils
diff options
context:
space:
mode:
authorJeremy Kerr <jk@ozlabs.org>2014-06-17 13:21:47 +0800
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-17 23:06:13 +0200
commit4ef1fb88faa3839f2209a251894abee37dd53c71 (patch)
treec8b74ef3a938d78627e6bd0d0d9e1d332c5f7d3b /package/powerpc-utils
parentf8f3073b18895bbf6938a5c310f6e6134f8bd6cb (diff)
package/powerpc-utils: Add powerpc hardware utilities
This change adds a package definition for the powerpc-utils project, containing a set of powerpc-specific hardware management utilities. We're using a git tag from upstream, which contains a few build-system fixes. [Thomas: - Add dependency on PowerPC architecture in Config.in. - Add homepage in Config.in help text.] Signed-off-by: Jeremy Kerr <jk@ozlabs.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/powerpc-utils')
-rw-r--r--package/powerpc-utils/Config.in8
-rw-r--r--package/powerpc-utils/powerpc-utils.mk16
2 files changed, 24 insertions, 0 deletions
diff --git a/package/powerpc-utils/Config.in b/package/powerpc-utils/Config.in
new file mode 100644
index 0000000000..eded41e7e5
--- /dev/null
+++ b/package/powerpc-utils/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_POWERPC_UTILS
+ bool "powerpc-utils"
+ depends on BR2_powerpc || BR2_powerpc64 || BR2_powerpc64le
+ select BR2_PACKAGE_ZLIB
+ help
+ System utilities for PowerPC machines.
+
+ http://sourceforge.net/projects/powerpc-utils/
diff --git a/package/powerpc-utils/powerpc-utils.mk b/package/powerpc-utils/powerpc-utils.mk
new file mode 100644
index 0000000000..c9cc0961aa
--- /dev/null
+++ b/package/powerpc-utils/powerpc-utils.mk
@@ -0,0 +1,16 @@
+################################################################################
+#
+# powerpc-utils
+#
+################################################################################
+
+POWERPC_UTILS_VERSION = v1.4
+POWERPC_UTILS_SITE = git://git.code.sf.net/p/powerpc-utils/powerpc-utils
+POWERPC_UTILS_AUTORECONF = YES
+POWERPC_UTILS_DEPENDENCIES = zlib
+POWERPC_UTILS_LICENSE = Common Public License Version 1.0
+POWERPC_UTILS_LICENSE_FILES = COPYRIGHT
+
+POWERPC_UTILS_CONF_OPT = --without-librtas
+
+$(eval $(autotools-package))