summaryrefslogtreecommitdiff
path: root/package/pkg-kernel-module.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-09-03 14:54:19 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-09-04 13:13:52 +0200
commitb7c32c98bc810b88e0391117f225658f82b44995 (patch)
tree00cfa6903c17b39cd24480726183bb59594ca8cc /package/pkg-kernel-module.mk
parentf07da1a5987d881f7133d664776d3cb8a85cc570 (diff)
core/pkg-kernel-module: ensure linux supports modules
When a package wants to build a kernel module, we should ensure that the kernel does support modules. This patch does it automatically for packages using the kernel-module infrastructure. Packages that do not use it will have to set it manually (to be done in a followup patch). Suggested-by: Peter Korsgaard <jacmet@uclibc.org> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Peter Korsgaard <jacmet@uclibc.org> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: NoƩ Rubinstein <noe.rubinstein@gmail.com> Cc: Jan Viktorin <viktorin@rehivetech.com> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pkg-kernel-module.mk')
-rw-r--r--package/pkg-kernel-module.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/pkg-kernel-module.mk b/package/pkg-kernel-module.mk
index 6fb7704e32..f6730b882d 100644
--- a/package/pkg-kernel-module.mk
+++ b/package/pkg-kernel-module.mk
@@ -44,6 +44,11 @@
define inner-kernel-module
+# If the package is enabled, ensure the kernel will support modules
+ifeq ($$(BR2_PACKAGE_$(2)),y)
+LINUX_NEEDS_MODULES = y
+endif
+
# The kernel must be built first.
$(2)_DEPENDENCIES += linux