summaryrefslogtreecommitdiff
path: root/package/pkg-download.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2019-04-15 21:47:23 +0200
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2019-04-15 23:18:25 +0200
commit813b94e6be3978cbe0097ec41fccdc33b1b6cd52 (patch)
treef96048422a7a91b0ad50d1c317ff3a340a75b1e5 /package/pkg-download.mk
parenta45a3997d8ee0aa592c6a64ce300ee727ad7dc54 (diff)
infra/pkg-download: return just a list of URIs
Currently, the internal DOWNLOAD_URIS variable is set to be a list of options to pass to the download wrapper, with each URI passed as '-u URI'. This precludes using that variable to get just the list of URIs, in case we need to do something else with it. Fix the variable to really only contain the list of URIs. Adapt the caller accordingly. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Diffstat (limited to 'package/pkg-download.mk')
-rw-r--r--package/pkg-download.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/pkg-download.mk b/package/pkg-download.mk
index 7cd87c38ff..4163333998 100644
--- a/package/pkg-download.mk
+++ b/package/pkg-download.mk
@@ -75,17 +75,17 @@ export BR_NO_CHECK_HASH_FOR =
ifneq ($(call qstrip,$(BR2_PRIMARY_SITE)),)
DOWNLOAD_URIS += \
- -u $(call getschemeplusuri,$(call qstrip,$(BR2_PRIMARY_SITE)/$($(PKG)_DL_SUBDIR)),urlencode) \
- -u $(call getschemeplusuri,$(call qstrip,$(BR2_PRIMARY_SITE)),urlencode)
+ $(call getschemeplusuri,$(call qstrip,$(BR2_PRIMARY_SITE)/$($(PKG)_DL_SUBDIR)),urlencode) \
+ $(call getschemeplusuri,$(call qstrip,$(BR2_PRIMARY_SITE)),urlencode)
endif
ifeq ($(BR2_PRIMARY_SITE_ONLY),)
DOWNLOAD_URIS += \
- -u $(patsubst %/,%,$(dir $(call qstrip,$(1))))
+ $(patsubst %/,%,$(dir $(call qstrip,$(1))))
ifneq ($(call qstrip,$(BR2_BACKUP_SITE)),)
DOWNLOAD_URIS += \
- -u $(call getschemeplusuri,$(call qstrip,$(BR2_BACKUP_SITE)/$($(PKG)_DL_SUBDIR)),urlencode) \
- -u $(call getschemeplusuri,$(call qstrip,$(BR2_BACKUP_SITE)),urlencode)
+ $(call getschemeplusuri,$(call qstrip,$(BR2_BACKUP_SITE)/$($(PKG)_DL_SUBDIR)),urlencode) \
+ $(call getschemeplusuri,$(call qstrip,$(BR2_BACKUP_SITE)),urlencode)
endif
endif
@@ -101,7 +101,7 @@ define DOWNLOAD
-N '$($(PKG)_RAWNAME)' \
-o '$($(PKG)_DL_DIR)/$(notdir $(1))' \
$(if $($(PKG)_GIT_SUBMODULES),-r) \
- $(DOWNLOAD_URIS) \
+ $(foreach uri,$(DOWNLOAD_URIS),-u $(uri)) \
$(QUIET) \
-- \
$($(PKG)_DL_OPTS)