summaryrefslogtreecommitdiff
path: root/package/openpowerlink
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@openwide.fr>2014-05-09 01:05:12 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-05-15 23:08:35 +0200
commit8dda4eb3bd65fdf9eff0422e0e974e0a1d012015 (patch)
treeec9f58c8defb1a0b90377c0138c02889c7475543 /package/openpowerlink
parent8e5b15d9e7ca16e0413bd002424843319eae676e (diff)
openpowerlink: use git repository instead of zip archive
Since commit 6c5c08b854e4490697076ae3c5a9c587d8672c63, openpowerlink package is rebuilt at every make call because .stamp_downloaded is missing in the build directory.[D The culprit is OPENPOWERLINK_EXTRACT_CMDS that remove and replace the build directory. unzip extract a directory "openPOWERLINK-V1.08.4" and Buildroot expect a directory "openpowerlink-V1.08.4" It is easier to use git repository instead of zip archive and avoids rename the directory openPOWERLINK to openpowerlink. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/openpowerlink')
-rw-r--r--package/openpowerlink/openpowerlink.mk12
1 files changed, 2 insertions, 10 deletions
diff --git a/package/openpowerlink/openpowerlink.mk b/package/openpowerlink/openpowerlink.mk
index 37a06e52c6..0aae54486c 100644
--- a/package/openpowerlink/openpowerlink.mk
+++ b/package/openpowerlink/openpowerlink.mk
@@ -5,9 +5,8 @@
################################################################################
OPENPOWERLINK_VERSION = V1.08.4
-OPENPOWERLINK_SOURCE = openPOWERLINK-$(OPENPOWERLINK_VERSION).zip
-OPENPOWERLINK_SITE = http://downloads.sourceforge.net/project/openpowerlink/openPOWERLINK/V1.8.4
-
+OPENPOWERLINK_SITE = http://git.code.sf.net/p/openpowerlink/code
+OPENPOWERLINK_SITE_METHOD = git
OPENPOWERLINK_LICENSE = BSD-2c, GPLv2
OPENPOWERLINK_LICENSE_FILES = license.txt
OPENPOWERLINK_INSTALL_STAGING = YES
@@ -89,11 +88,4 @@ else
OPENPOWERLINK_CONF_OPT += -DCFG_X86_DEMO_LINUX_KERNEL=OFF
endif
-define OPENPOWERLINK_EXTRACT_CMDS
- $(RM) -rf $(OPENPOWERLINK_DIR)
- unzip -q -d $(BUILD_DIR)/ $(DL_DIR)/$(OPENPOWERLINK_SOURCE)
- test -d $(OPENPOWERLINK_DIR) || \
- mv $(BUILD_DIR)/$(subst .zip,,$(OPENPOWERLINK_SOURCE)) $(OPENPOWERLINK_DIR)
-endef
-
$(eval $(cmake-package))