summaryrefslogtreecommitdiff
path: root/package/openipmi
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-21 10:50:09 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-21 12:41:56 +0100
commit33b6119d87e8eea6244894f914ce51f4bce1efa9 (patch)
tree270954ff5b1a085767016aeaa896c3ef0d3ebb7f /package/openipmi
parent5da3186efbeeff49ea4dc1774280d7cc2899c27f (diff)
package/openipmi: add optional support for gdbm
When gdbm was compiled before, openipmi will use it as optional dependency: $ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/ipmi_sim | grep NEEDED | sort 0x0000000000000001 (NEEDED) Shared library: [libc.so.1] 0x0000000000000001 (NEEDED) Shared library: [libdl.so.1] 0x0000000000000001 (NEEDED) Shared library: [libgdbm.so.4] [...] The build system offers no option to en-/disable gdbm support, check configure.ac, line 309+ Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/openipmi')
-rw-r--r--package/openipmi/openipmi.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/openipmi/openipmi.mk b/package/openipmi/openipmi.mk
index 4dd901b2bc..ea46e191da 100644
--- a/package/openipmi/openipmi.mk
+++ b/package/openipmi/openipmi.mk
@@ -23,6 +23,10 @@ OPENIPMI_CONF_OPTS = \
--with-python=no \
--with-swig=no
+ifeq ($(BR2_PACKAGE_GDBM),y)
+OPENIPMI_DEPENDENCIES += gdbm
+endif
+
ifeq ($(BR2_PACKAGE_OPENSSL),y)
OPENIPMI_DEPENDENCIES += openssl
OPENIPMI_CONF_OPTS += --with-openssl=yes