summaryrefslogtreecommitdiff
path: root/package/nfs-utils
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-21 15:48:43 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-21 18:21:26 +0100
commitbe589759ee12d47a44512cb5a4b17f5824991aa5 (patch)
tree252395ac3488db4246f6e5256b0b308f7d70ffb6 /package/nfs-utils
parent46143f16834987dce379a88d98ce7068cabfe29f (diff)
package/nfs-utils: add optional support for libcap
When libcap was compiled before, nfs-utils will use it as optional dependency: $ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/sbin/sm-notify | grep NEEDED 0x0000000000000001 (NEEDED) Shared library: [libcap.so.2] 0x0000000000000001 (NEEDED) Shared library: [libtirpc.so.3] 0x0000000000000001 (NEEDED) Shared library: [libpthread.so.1] 0x0000000000000001 (NEEDED) Shared library: [libc.so.1] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/nfs-utils')
-rw-r--r--package/nfs-utils/nfs-utils.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/nfs-utils/nfs-utils.mk b/package/nfs-utils/nfs-utils.mk
index 6dd175cadb..179009dc5f 100644
--- a/package/nfs-utils/nfs-utils.mk
+++ b/package/nfs-utils/nfs-utils.mk
@@ -28,6 +28,13 @@ NFS_UTILS_TARGETS_$(BR2_PACKAGE_NFS_UTILS_RPCDEBUG) += usr/sbin/rpcdebug
NFS_UTILS_TARGETS_$(BR2_PACKAGE_NFS_UTILS_RPC_LOCKD) += usr/sbin/rpc.lockd
NFS_UTILS_TARGETS_$(BR2_PACKAGE_NFS_UTILS_RPC_RQUOTAD) += usr/sbin/rpc.rquotad
+ifeq ($(BR2_PACKAGE_LIBCAP),y)
+NFS_UTILS_CONF_OPTS += --enable-caps
+NFS_UTILS_DEPENDENCIES += libcap
+else
+NFS_UTILS_CONF_OPTS += --disable-caps
+endif
+
ifeq ($(BR2_PACKAGE_LIBTIRPC),y)
NFS_UTILS_CONF_OPTS += --enable-tirpc
NFS_UTILS_DEPENDENCIES += libtirpc