summaryrefslogtreecommitdiff
path: root/package/mesa3d-demos/0001-demos-makes-opengl-an-optional-component.patch
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@gmail.com>2018-02-24 12:12:14 +0100
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-02-25 22:06:46 +0100
commitee5efb464418fb31c6c96434f4ede4f83f8afb0c (patch)
treea00e0224b8d8e06c0797ed6670534fc468bd440d /package/mesa3d-demos/0001-demos-makes-opengl-an-optional-component.patch
parentcc2f3a2a5924934b14a078d914ad3c4d731f3e8a (diff)
package/mesa3d-demos: bump to 8.4.0
Use the new upstream url. Added all hashes provided by upstream. Rebase patch on top of 8.4.0 and convert it to git formated patch. Add a comment above "MESA3D_DEMOS_AUTORECONF = YES" See https://lists.freedesktop.org/archives/mesa-dev/2018-February/186542.html Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/mesa3d-demos/0001-demos-makes-opengl-an-optional-component.patch')
-rw-r--r--package/mesa3d-demos/0001-demos-makes-opengl-an-optional-component.patch88
1 files changed, 88 insertions, 0 deletions
diff --git a/package/mesa3d-demos/0001-demos-makes-opengl-an-optional-component.patch b/package/mesa3d-demos/0001-demos-makes-opengl-an-optional-component.patch
new file mode 100644
index 0000000000..b328fca810
--- /dev/null
+++ b/package/mesa3d-demos/0001-demos-makes-opengl-an-optional-component.patch
@@ -0,0 +1,88 @@
+From bb0ffae7164d296d32da24fa5499534de259169a Mon Sep 17 00:00:00 2001
+From: Spenser Gilliland <spenser@gillilanding.com>
+Date: Sat, 24 Feb 2018 11:36:17 +0100
+Subject: [PATCH] demos: makes opengl an optional component
+
+Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
+[Romain: convert to git patch, rebase on 8.4.0]
+Signed-off-by: Romain Naour <romain.naour@gmail.com>
+---
+ configure.ac | 12 +++++++++++-
+ src/egl/opengl/Makefile.am | 2 ++
+ src/util/Makefile.am | 2 ++
+ 3 files changed, 15 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0b5e9a76..24298c44 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -51,6 +51,14 @@ m4_ifndef([PKG_PROG_PKG_CONFIG],
+ ACLOCAL="aclocal -I/other/macro/dir" before running autoreconf.])])
+ PKG_PROG_PKG_CONFIG()
+
++AC_ARG_ENABLE([gl],
++ [AS_HELP_STRING([--enable-gl],
++ [enable GL library @<:@default=no@:>@])],
++ [gl_enabled="$enableval"],
++ [gl_enabled=auto])
++
++if test "x$gl_enabled" != "xno"; then
++
+ dnl Get the pkg-config definitions for libGL. We include a fallback
+ dnl path for GL implementation that don't provide a .pc file
+ PKG_CHECK_MODULES(GL, [gl], [], [
+@@ -112,6 +120,8 @@ PKG_CHECK_MODULES(GLU, [glu], [],
+ DEMO_CFLAGS="$DEMO_CFLAGS $GLU_CFLAGS"
+ DEMO_LIBS="$DEMO_LIBS $GLU_LIBS"
+
++fi
++
+ AC_ARG_ENABLE([egl],
+ [AS_HELP_STRING([--enable-egl],
+ [enable EGL library @<:@default=auto@:>@])],
+@@ -302,7 +312,7 @@ AC_SUBST([MESA_GLAPI])
+ AC_SUBST([WAYLAND_CFLAGS])
+ AC_SUBST([WAYLAND_LIBS])
+
+-
++AM_CONDITIONAL(HAVE_GL, test "x$gl_enabled" = "xyes")
+ AM_CONDITIONAL(HAVE_EGL, test "x$egl_enabled" = "xyes")
+ AM_CONDITIONAL(HAVE_GLESV1, test "x$glesv1_enabled" = "xyes")
+ AM_CONDITIONAL(HAVE_GLESV2, test "x$glesv2_enabled" = "xyes")
+diff --git a/src/egl/opengl/Makefile.am b/src/egl/opengl/Makefile.am
+index 6d184ff6..219ab850 100644
+--- a/src/egl/opengl/Makefile.am
++++ b/src/egl/opengl/Makefile.am
+@@ -56,6 +56,7 @@ endif
+ endif
+
+ if HAVE_EGL
++if HAVE_GL
+ bin_PROGRAMS = \
+ eglinfo
+ noinst_PROGRAMS = \
+@@ -64,6 +65,7 @@ noinst_PROGRAMS = \
+ $(EGL_X11_DEMOS) \
+ $(EGL_WL_DEMOS)
+ endif
++endif
+
+ egltri_x11_SOURCES = egltri.c
+ eglgears_x11_SOURCES = eglgears.c
+diff --git a/src/util/Makefile.am b/src/util/Makefile.am
+index 759a293a..012b9c75 100644
+--- a/src/util/Makefile.am
++++ b/src/util/Makefile.am
+@@ -27,7 +27,9 @@ AM_CFLAGS = \
+ AM_LDFLAGS = \
+ $(DEMO_LIBS)
+
++if HAVE_GL
+ noinst_LTLIBRARIES = libutil.la
++endif
+
+ if HAVE_GLUT
+ AM_CFLAGS += \
+--
+2.14.3
+