summaryrefslogtreecommitdiff
path: root/package/lua-msgpack-native
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2014-01-17 18:47:36 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-01-21 23:27:50 +0100
commit751d85a7f835ab055dd16087991e08a22a14c364 (patch)
treeb38d09aab7091317e5d0154dcafde0d4164ef1ba /package/lua-msgpack-native
parentba296ab1eaeab5ab68c596f7723932788749c9c6 (diff)
lua-modules: choice between Lua 5.1.x & Lua 5.2.x
Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/lua-msgpack-native')
-rw-r--r--package/lua-msgpack-native/Config.in4
-rw-r--r--package/lua-msgpack-native/lua-msgpack-native.mk3
2 files changed, 6 insertions, 1 deletions
diff --git a/package/lua-msgpack-native/Config.in b/package/lua-msgpack-native/Config.in
index 1014298c78..498b30cb2b 100644
--- a/package/lua-msgpack-native/Config.in
+++ b/package/lua-msgpack-native/Config.in
@@ -1,8 +1,12 @@
config BR2_PACKAGE_LUA_MSGPACK_NATIVE
bool "lua-msgpack-native"
depends on BR2_PACKAGE_HAS_LUA_INTERPRETER
+ depends on !BR2_PACKAGE_LUA_5_2
help
This is a native, C language implementation of msgpack
(http://msgpack.org) library/protocol for Lua language
https://github.com/kengonakajima/lua-msgpack-native
+
+comment "lua-msgpack-native needs a Lua 5.1 interpreter"
+ depends on BR2_PACKAGE_LUA_5_2
diff --git a/package/lua-msgpack-native/lua-msgpack-native.mk b/package/lua-msgpack-native/lua-msgpack-native.mk
index d4547aef6a..ceb453dc11 100644
--- a/package/lua-msgpack-native/lua-msgpack-native.mk
+++ b/package/lua-msgpack-native/lua-msgpack-native.mk
@@ -15,7 +15,8 @@ define LUA_MSGPACK_NATIVE_BUILD_CMDS
endef
define LUA_MSGPACK_NATIVE_INSTALL_TARGET_CMDS
- $(INSTALL) -m 755 -D $(@D)/msgpack.so $(TARGET_DIR)/usr/lib/lua/5.1/msgpack.so
+ $(INSTALL) -m 755 -D $(@D)/msgpack.so \
+ $(TARGET_DIR)/usr/lib/lua/$(LUAINTERPRETER_ABIVER)/msgpack.so
endef
$(eval $(generic-package))