summaryrefslogtreecommitdiff
path: root/package/ltp-testsuite
diff options
context:
space:
mode:
authorMarc Gonzalez <marc_gonzalez@sigmadesigns.com>2016-04-05 13:09:40 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-04-18 21:40:11 +0200
commit44df0aeb6a61ee75db2be99418bca722b93a29ba (patch)
treec7ee4885bce0fca66954dc2e908665eedb56ed5b /package/ltp-testsuite
parent20e738bc3f938bf3c71752b4f78ccc28c274d531 (diff)
ltp-testsuite: build kernel modules when appropriate
If we're building a kernel, we can also build LTP's test modules. Signed-off-by: Marc Gonzalez <marc_gonzalez@sigmadesigns.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/ltp-testsuite')
-rw-r--r--package/ltp-testsuite/ltp-testsuite.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/ltp-testsuite/ltp-testsuite.mk b/package/ltp-testsuite/ltp-testsuite.mk
index 8adfdef68d..cf48072f81 100644
--- a/package/ltp-testsuite/ltp-testsuite.mk
+++ b/package/ltp-testsuite/ltp-testsuite.mk
@@ -13,6 +13,14 @@ LTP_TESTSUITE_CONF_OPTS += \
--with-power-management-testsuite \
--with-realtime-testsuite
+ifeq ($(BR2_LINUX_KERNEL),y)
+LTP_TESTSUITE_DEPENDENCIES += linux
+LTP_TESTSUITE_MAKE_ENV += $(LINUX_MAKE_FLAGS)
+LTP_TESTSUITE_CONF_OPTS += --with-linux-dir=$(LINUX_DIR)
+else
+LTP_TESTSUITE_CONF_OPTS += --without-modules
+endif
+
# Needs libcap with file attrs which needs attr, so both required
ifeq ($(BR2_PACKAGE_LIBCAP)$(BR2_PACKAGE_ATTR),yy)
LTP_TESTSUITE_DEPENDENCIES += libcap