summaryrefslogtreecommitdiff
path: root/package/lldpd
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2019-04-07 21:58:30 +0200
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2019-04-10 19:31:19 +0200
commitaa1c8e7370f295e6f373cdab0c6bc0d3a124dd8a (patch)
tree355a44675344d20f72fe9ce016f59fe6b7939620 /package/lldpd
parent2bbe9c41c69176d09863c356e307de2d9ed5cb94 (diff)
package/lldpd: add optional netsnmp dependency
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/lldpd')
-rw-r--r--package/lldpd/lldpd.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/package/lldpd/lldpd.mk b/package/lldpd/lldpd.mk
index 506b6f136d..4e62f56c5d 100644
--- a/package/lldpd/lldpd.mk
+++ b/package/lldpd/lldpd.mk
@@ -29,7 +29,6 @@ LLDPD_CONF_ENV = ac_cv_prog_cc_c99=-std=gnu99
LLDPD_CONF_OPTS = \
--without-embedded-libevent \
- --without-snmp \
--without-xml \
--without-seccomp \
--without-libbsd \
@@ -44,6 +43,15 @@ LLDPD_CONF_OPTS = \
$(if $(BR2_PACKAGE_LLDPD_DOT3),--enable-dot3,--disable-dot3) \
$(if $(BR2_PACKAGE_LLDPD_CUSTOM_TLV),--enable-custom,--disable-custom)
+ifeq ($(BR2_PACKAGE_NETSNMP),y)
+LLDPD_CONF_OPTS += --with-snmp
+LLDPD_DEPENDENCIES += netsnmp
+LLDPD_CONF_ENV += \
+ ac_cv_path_NETSNMP_CONFIG=$(STAGING_DIR)/usr/bin/net-snmp-config
+else
+LLDPD_CONF_OPTS += --without-snmp
+endif
+
ifeq ($(BR2_PACKAGE_READLINE),y)
LLDPD_CONF_OPTS += --with-readline
LLDPD_DEPENDENCIES += readline