summaryrefslogtreecommitdiff
path: root/package/lldpd
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-12-10 16:48:22 +0100
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-12-13 22:20:22 +0100
commit9947b87877b5057d4d6f2ac69a20b42f1ec28fdc (patch)
treee44eb3996967f5baa2f8ab48e770c7630c35ebc0 /package/lldpd
parentbc60c57f6920ce055acb11ef4e3e7c2123ce9bf7 (diff)
package/lldpd: fix readline dependency
lldpd can optionally depend on readline, but readline is never added to LLDPD_DEPENDENCIES, which this commit fixes. This was detected using per-package directories. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/lldpd')
-rw-r--r--package/lldpd/lldpd.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/lldpd/lldpd.mk b/package/lldpd/lldpd.mk
index 939cd128fa..6a520448da 100644
--- a/package/lldpd/lldpd.mk
+++ b/package/lldpd/lldpd.mk
@@ -36,7 +36,6 @@ LLDPD_CONF_OPTS = \
--without-libbsd \
--disable-hardening \
--disable-privsep \
- $(if $(BR2_PACKAGE_READLINE),--with-readline,--without-readline) \
$(if $(BR2_PACKAGE_LLDPD_CDP),--enable-cdp,--disable-cdp) \
$(if $(BR2_PACKAGE_LLDPD_FDP),--enable-fdp,--disable-fdp) \
$(if $(BR2_PACKAGE_LLDPD_EDP),--enable-edp,--disable-edp) \
@@ -46,6 +45,13 @@ LLDPD_CONF_OPTS = \
$(if $(BR2_PACKAGE_LLDPD_DOT3),--enable-dot3,--disable-dot3) \
$(if $(BR2_PACKAGE_LLDPD_CUSTOM_TLV),--enable-custom,--disable-custom)
+ifeq ($(BR2_PACKAGE_READLINE),y)
+LLDPD_CONF_OPTS += --with-readline
+LLDPD_DEPENDENCIES += readline
+else
+LLDPD_CONF_OPTS += --without-readline
+endif
+
define LLDPD_INSTALL_INIT_SYSV
$(INSTALL) -D -m 0755 package/lldpd/S60lldpd \
$(TARGET_DIR)/etc/init.d/S60lldpd